Cant force quit, cause it's only half running or something?!

Discussion in 'macOS' started by big_malk, Sep 4, 2007.

  1. big_malk macrumors 6502a

    Joined:
    Aug 7, 2005
    Location:
    Scotland
    #1
    I've had eyeTV open in the background for a few days now (no shut down or sleep) and when I tried to use it again, it had crashed. No problem I thought, force quit. Didn't work.
    The windows all closed, but the dock triangle hasn't gone, and it isn't showing up in activity monitor.
    I've tried force quitting a few times, and given it plenty time to do it. If I click on the dock icon, the front window loses focus, but the application menu stays as Safari, for example.

    I read about using the "top" command in terminal to get a list of all running processes (although this should be identical to activity monitor?) but for some reason I can't scroll down the list in terminal? If I drag the window bigger I can see more of the list, but not enough to see it all and I just cant scroll down:confused: so I can't see the PID number, but I could get it from activity monitor... if it was in the list...:confused:

    I dont want to restart cause I have stuff running thats been working for a while, but I'd like to watch TV while its working :(
     
  2. Multimedia macrumors 603

    Multimedia

    Joined:
    Jul 27, 2001
    Location:
    Santa Cruz CA, Silicon Beach
    #2
    You Have To Shut The Mac OFF For A Moment

    Sorry, no way around having to turn off the Mac for a moment and starting over. We all have to do it from time to time. Fact of life. :)
     
  3. JackRipper macrumors regular

    JackRipper

    Joined:
    May 14, 2002
    Location:
    Culpeper, Va
    #3
    Actually, you can get the PID using the ps command from the terminal.

    ps -A | grep "PART_OF_APP_NAME" | grep -v "grep"

    PART_OF_APP_NAME can be just the first few letters, but it is case sensitive.

    The PID is in the first column, then run:
    kill -9 PID
    or
    sudo kill -9 PID

    depending on if your user started the process.

    Multimedia does have a point, though. Sounds like it's time to restart. You can't scroll???? Can't say I've seen that before.
     
  4. big_malk thread starter macrumors 6502a

    Joined:
    Aug 7, 2005
    Location:
    Scotland
    #4
    I tried what you said , JackRipper, and terminal returned "12042 ?? E 0:00.00 (EyeTV)", which I assume means it wasnt found as a process? The same way it doesn't show in Activity Monitor.

    What?! You mean I have to restart a Mac every so often?! Gosh, you'd think I was using a PC or something :eek:

    Well, it's been working hard 5 days and 6 hours so far, and apart from this not had a single problem :) but maybe it is time for a restart lol

    Well, I can scroll, just not down past the bottom of the window. The results of 'top' fill the window and no more, if I resize the window the results adjust to show more or less. If I scroll up, I can scroll down, but not past the bottom of the results.

    I have had a few strange problems like this, such as a folder I just cant delete. Think I need a clean install, but I'm holding out for Leopard :apple:
     

Share This Page