Can't Format Second HDD

Discussion in 'Mac mini' started by cpadfw, Feb 26, 2012.

  1. cpadfw macrumors newbie

    Joined:
    Feb 26, 2012
    Location:
    Texas
    #1
    Using kit from iFixit, I added 2nd HDD (Seagate Momentus XT ST750LX003 750GB). Installation seems fine, Mini recognizes drive.

    When I try to format, using Mac OS Extended (Journaled), it begins, then fails with the following error:

    Disk Erase failed

    Disk Erase failed with the error:

    File system formatter failed.​

    Partition information then shows the name as diskOs2 with the Mac OS Extended as the type.

    I can change the number of partitions, but it still gives the same error when I try to format one of the partitions.

    Any ideas appreciated.
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    What partition map scheme have you selected under OPTIONS?

    [​IMG]
     
  3. cpadfw thread starter macrumors newbie

    Joined:
    Feb 26, 2012
    Location:
    Texas
    #3
    I chose 1 partition, but have also tried 2 or more. In the options, I chose GUID Partition Table.

    I then get the error:

    Partition Failed

    Partition failed with error:

    Wiping volume data to prevent future accidental probing failed.​
     
  4. Bear macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #4
    Have you checked to see if Seagate has newer firmware for the Momentus?

    Does the Momentus have any jumpers or switches on it?

    GUID is right.

    And there is always the chance you got a bad drive.
     
  5. cpadfw thread starter macrumors newbie

    Joined:
    Feb 26, 2012
    Location:
    Texas
    #5
    No new firmware, jumpers say factory only and I don't think they serve any function on the new drive.

    Drive is buried in the bowels of the mini, so I can't say for sure what the jumper settings are.
     
  6. Buckeyes1995 macrumors member

    Joined:
    Mar 4, 2011
    #6
    I had a very similar error. My issue turned out being a bad SATA cable. The drive was recognized fine, but no matter what I did, trying to partition and format caused it to error out.. and I even saw the "Wiping volume.." error message you have above.

    May or may not be the cause.
     

Share This Page