Can't get 2014 MBA to connect to a TV

Discussion in 'MacBook Air' started by motrek, Sep 20, 2014.

  1. motrek macrumors 68020

    Joined:
    Sep 14, 2012
    #1
    I'm having a weird problem with a particular TV.

    I am trying to connect my 2014 11.6" MBA to it. I have the MBA, displayport-HDMI adapter, HDMI cable, and TV.

    I hooked everything up and it worked okay for about 10 seconds. Then I started to play some video on the MBA and the top 1/3 of the TV image turned to random pixels. I fidgeted a bit with the cables and now I can't get anything to show up on the TV at all. When I plug the TV into the MBA, the MBA seems to recognize that something happened and the screen will flash but that's it. Nothing shows up in the Displays control panel, etc. TV just says no signal.

    Any suggestions? Is this some kind of firmware issue. I checked for updates and there aren't any.

    MBA and displayport adapter -- I'm pretty sure these work since I was able to connect them to a different TV a few weeks ago

    HDMI cable and TV -- I know these work because I connected them to a DVD player and that worked

    Appreciate any ideas in advance!
     
  2. illusionx macrumors 6502

    Joined:
    Jul 4, 2014
    Location:
    Brossard, QC
    #2
    I would try using a different tv again. Just to make sure it isn't the minidisplayport adapter.
     
  3. motrek thread starter macrumors 68020

    Joined:
    Sep 14, 2012
    #3
    Yeah, might do. Thanks. I'm traveling now so that's not convenient, but I'll see if I can't sort something out.
     

Share This Page