Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Can't get airplay to show up on imac/macbook pro, but it works from iphone? Any ideas?

iemcj

macrumors 6502
Original poster
Oct 31, 2015
456
150
So I recently got a new Vizio tv and it supports Airplay 2 out of the box. I tested it out from my iphone and i was able to easily stream some video from my iphone. Nice.

However it doesn't show up at all using either my 2015 nor my 2017 imac. All on the same wifi network of course and latest available OSx. I followed all the instructions I could find online including under preferences, displays, and checking the little box showing "show mirroring options in the menu bar when available". But the "airplay display" option is set to off and it doesn't give me an option to turn it on. Am I missing something to get that rocking? Thanks guys!
 

waw74

macrumors 68040
May 27, 2008
3,722
439
do you have any other airplay devices in your house that do work?

try toggling mac's wi-fi off and on. it's a quick step that might help, if not...
try rebooting your router, Mac, and other network devices.
sometimes routers get a bit screwy with the network broadcasts that airplay uses especially over wifi.

the "airplay display" option should be a drop down list, the top option is off, and it fills in with the other items below.

if that doesn't work
get bonjour browser - https://apps.apple.com/us/app/discovery-dns-sd-browser/id1381004916?mt=12

launch that,
in the list you should see "_airplay._tcp."
expand that, and you should see your TV, and any other airplay devices.
this will show you that at least the network broadcast announcements are making it to your Mac.
 

iemcj

macrumors 6502
Original poster
Oct 31, 2015
456
150
Thank you! I toggled wifi on and off and have done a few total resets over the last few days and no dice.

I rebooted the router as in turning it off and back on (Timecapsule). I could perhaps try to completely reset the router to factory defaults if you think that may help?

Yeah there is no dropdown list, just "off" and when I click it there's no other options.

I got that bonjour browser you suggested and yes I see it on there. _airplay._tcp. then "Office TV" as I have it labeled.

I'll give the full wipe a go here later today but in the meantime I wanted to update you with this in case you can think of anything else. Thanks!
 

priitv8

macrumors 68040
Jan 13, 2011
3,685
506
Estonia
Also the advertised features play a role.
I have no documentation to decode those codewords, but for reference here are those reported by apple TV 4
43F0D913-7E2F-4065-A547-66C97E9435F1.jpeg
 

chabig

macrumors 604
Sep 6, 2002
7,305
4,544
You said your Macs are running the latest OS—confirm macOS 10.14.6?

It should work. Here are Apple's system requirements: https://support.apple.com/en-us/HT208728

And here is a list of troubleshooting tips from https://appletoolbox.com/apple-help...-your-problems/#How_do_I_fix_AirPlay_problems
  • Check your Apple device and AirPlay device are using the same Wi-Fi network.
  • Make sure your Apple TV or AirPlay device is powered on and awake.
  • Turn off and on Bluetooth on your iOS device. Do this from Control Center or go to Settings > General > Bluetooth.
  • Turn off and on Wi-Fi on your iOS device. Do this from Control Center or go to Settings > General > Wi-Fi.
  • Check your Wi-Fi router’s firmware is up to date.
  • Update your Apple TV to the latest software by going to Settings > General > Update Software.
  • Update your iOS device to the latest software by going to Settings > General > Software Update.
  • Reboot your Wi-Fi router
  • Restart your AirPlay device or Apple TV; you may need to disconnect power to do this.
  • Restart your iOS device; press and hold the Side button with either Volume button, then slide to power off.
  • Make sure there is only one device trying to stream at any time.
  • Some third-party apps interfere with AirPlay. In particular, apps that offer similar functions as AirPlay, such as Duet and AirParrot. Uninstall any apps that send your screen or media files to other devices.
  • Turn off restrictions from Settings > Screen Time > Content & Privacy Restrictions.
 

iemcj

macrumors 6502
Original poster
Oct 31, 2015
456
150
<blockquote class="imgur-embed-pub" lang="en" data-id="a/5f3Eu4G" data-context="false" ><a href="//imgur.com/a/5f3Eu4G"></a></blockquote><script async src="//s.imgur.com/min/embed.js" charset="utf-8"></script>
[doublepost=1566673389][/doublepost]
You said your Macs are running the latest OS—confirm macOS 10.14.6?

It should work. Here are Apple's system requirements: https://support.apple.com/en-us/HT208728

And here is a list of troubleshooting tips from https://appletoolbox.com/apple-help...-your-problems/#How_do_I_fix_AirPlay_problems
  • Check your Apple device and AirPlay device are using the same Wi-Fi network.
  • Make sure your Apple TV or AirPlay device is powered on and awake.
  • Turn off and on Bluetooth on your iOS device. Do this from Control Center or go to Settings > General > Bluetooth.
  • Turn off and on Wi-Fi on your iOS device. Do this from Control Center or go to Settings > General > Wi-Fi.
  • Check your Wi-Fi router’s firmware is up to date.
  • Update your Apple TV to the latest software by going to Settings > General > Update Software.
  • Update your iOS device to the latest software by going to Settings > General > Software Update.
  • Reboot your Wi-Fi router
  • Restart your AirPlay device or Apple TV; you may need to disconnect power to do this.
  • Restart your iOS device; press and hold the Side button with either Volume button, then slide to power off.
  • Make sure there is only one device trying to stream at any time.
  • Some third-party apps interfere with AirPlay. In particular, apps that offer similar functions as AirPlay, such as Duet and AirParrot. Uninstall any apps that send your screen or media files to other devices.
  • Turn off restrictions from Settings > Screen Time > Content & Privacy Restrictions.
Hmm I'm on OS 10.14.1, that's actually a good thing to check because yeah I've done all those things. I'll start that update now and get back to ya if that works!
 

chabig

macrumors 604
Sep 6, 2002
7,305
4,544
I'm on OS 10.14.1
You said in the original post that you were running the latest version, but you’re not. That’s the problem. Airplay 2 requires 10.14.5 or later. 10.14.6 is the current version. Once you update it will work.
 

iemcj

macrumors 6502
Original poster
Oct 31, 2015
456
150
You said in the original post that you were running the latest version, but you’re not. That’s the problem. Airplay 2 requires 10.14.5 or later. 10.14.6 is the current version. Once you update it will work.

Yep that did indeed fix it, I normally see a little ticker in the top right letting me know an update is available but there wasn't anything until I manually went into about and clicked software update.

So I feel kinda dumb now that I missed the very first thing in the debugging process but I'm glad it's working! It's dissappointingly choppy and almost unusable for video (after a look around online this is a comon complaint, even with an Airport Extreme router) but at least I can use it as a second screen.
 

waw74

macrumors 68040
May 27, 2008
3,722
439
It's dissappointingly choppy and almost unusable for video (after a look around online this is a comon complaint, even with an Airport Extreme router)

if you can hardwire one of the devices, that will help.
all wireless goes through the router, so the video stream is being sent wirelessly twice, (Mac -> router, router -> aTV) doubling your chance for interference. And since your Mac and aTV are in the same room, if one has bad reception, the other probably does too.

an airport router doesn't have any magic to make it better, and actually they're fairly old in the world of routers.

You might have better luck with...
  • moving your router to a new location
  • getting a wifi extender
  • powerline networking wifi extender
  • upgrading to a mesh router (Eero, orbi, or similar),
For router location. think of a straight line from your device to the router, and picture what it passes through.
If there are walls, furniture or electronics in the way, they can interfere.

with Wifi extenders you have to keep in mind they can only repeat what they receive, so make sure you place it in a location that still has good signal, but is closer to where you need the boosted signal than your router is
wifi extenders typically also use the same radio to talk to both the main router and the devices it's repeating to, so your bandwidth can be affected, since the radio is doing double duty.

with powerline networking ...
You plug a box into the wall by your router, and run an ethernet cable to it.
You then plug a second box where the signal is weak, the 2 boxes connect over the powerlines in your house, and the second box creates a wifi network
Powerline can be a better option than the regular extender, since it doesn't have to be placed where there is already good signal. and the radios are only used to talk to devices, while the main connection back to the router goes over the powerline.

Mesh routers add a third radio that links back too the main router, leaving the other radios free to talk to your devices. They're also smart enough to figure out if it's better to connect to another repeater or directly to the router.

*and just a note, since I've seen people bring it up when talking about this, The speed you get from your internet provider is irrelevant in this instance, since the signal never leaves your house.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.