Can't get albums to sort together in iTunes

Discussion in 'macOS' started by Gen, Oct 25, 2010.

  1. Gen macrumors 6502a

    Gen

    Joined:
    Jul 15, 2008
    #1
    [​IMG]

    The only thing those have in common is the album name. I don't know what I'm doing wrong here, why can't they be shown separately?

    ps; "greatest hits" is the biggest mess, it's just ridiculous
     
  2. EricNau Moderator emeritus

    EricNau

    Joined:
    Apr 27, 2005
    Location:
    San Francisco, CA
    #2
    If you click on the "Album" header (i.e. the button you would use to change the sorting order), it will give you the option to sort "Album by Artist."

    Does this give you the results you want?
     
  3. Gen thread starter macrumors 6502a

    Gen

    Joined:
    Jul 15, 2008
    #3
    That doesn't put the order by Album first though :(
    I need it ordered by Album, primarily - but if I do it mixes the albums together, even if it's by a different artist.
     
  4. EricNau Moderator emeritus

    EricNau

    Joined:
    Apr 27, 2005
    Location:
    San Francisco, CA
    #4
    I'm not sure I understand what you mean. :confused:
     
  5. Gen thread starter macrumors 6502a

    Gen

    Joined:
    Jul 15, 2008
    #5
    [​IMG]

    It sorts it by artists name - instead of the albums name.
     
  6. EricNau Moderator emeritus

    EricNau

    Joined:
    Apr 27, 2005
    Location:
    San Francisco, CA
    #6
    Indeed you're right; I hadn't noticed that before. I think that may be as close as you can get, though, without altering the Sort options of each album/song individually. (That can be done by selecting a song [or more than one song] and pressing Cmd+i, and selecting the "Sort" tab.)
     
  7. FourCandles macrumors 6502a

    Joined:
    Feb 10, 2009
    Location:
    England
    #7
    Well, if nothing else then this thread has made me realise that in 600 albums I only have two with the same name, and they are "Greatest Hits" :)

    Seriously though, iTunes doesn't have this issue for me. When sorting by Album alone, those two Greatest Hits albums are separated correctly into the two artists concerned, unlike the OP's first screenshot. However, i do remember having to play around with the sorting options when I upgraded to iTunes 10 so I'll have another look around and see if I can remember what I had to do.
     
  8. batsun macrumors newbie

    Joined:
    Jul 22, 2010
    Location:
    Sydney, Australia
    #8
    maybe go into the info of the files of each album, make sure they say disc 1 of 1, hopefully that will group them together. I just change everything so that only one set of songs belong to one album.
     
  9. jackstraw111 macrumors newbie

    Joined:
    Oct 9, 2008
    #9
    If you go to "view options" or enter apple-J, you will get a menu of which columns you would like to see on the iTunes music window. You can uncheck album artist and then check album, and I think you will get the result you're looking for.

    Additionally, any new playlists you create will take on the same set of column views that the music library has.

    I typically have my iTunes library columns set for name, time, artist, album, plays, last played and kind, but that's just works best for me.



    Looking closer, I think I understand what you're trying to do. (Maybe.)

    I'd try telling iTunes to first sort the library using the artists column view, then click on the album view and see if that keeps the artists together with their album titles.

    I'll have to get to my home library and fiddle around with it and see what happens. May be different for me because I keep my albums arranged as separate playlists -- just about the only way I can keep 15,000 songs organized. It's only the library itself that would be affected if I experiment with changing the way things sort out.
     
  10. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #10
    Do you have the correct information in the "Album Artist" field?
     
  11. Gen thread starter macrumors 6502a

    Gen

    Joined:
    Jul 15, 2008
    #11
    [​IMG]

    That's my problem.
    All the fields are cleared except for "name" and "album name" for all artists/albums.
    Also I have entered under disc numbers 1 of 1 for each album/artists.

    This is just really annoying that's all - and it only happens when I'm viewing all of my songs. Like if I search for greatest hits everything is kosher.
     
  12. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #12
    The problem is not with iTunes. You don't have the correct information in the "Album Artist" field. iTunes determines what belongs in an album by having the same information in the "Album" and "Album Artist" field. Correct or fill in your Album Artist and it should be fine.
     
  13. Gen thread starter macrumors 6502a

    Gen

    Joined:
    Jul 15, 2008
    #13
    Wow, I guess I'm stupid
    Solved my issue, thanks :tup:
     

Share This Page