Can't get anything to compile, please help

Discussion in 'Mac Programming' started by pauldavis, Sep 25, 2007.

  1. pauldavis macrumors newbie

    Joined:
    Sep 25, 2007
    #1
    Ok, so I am completely new to using XCode, but have a little experience with programming, just a high school class worth that i took 3 years ago

    Anyway, I decided to learn Cocoa to try to make a good accounting program

    Whenever I open any project and try to "build and go" i get the same error, here it is

    Building target "Accounting" - (1 error)
    Precompiling Accounting_Prefix.pch (1 error)
    Couldn't run 'usr/bin/gcc-3.3' because it does not refer to an accessible executable

    Build failed for target "Accounting" using build style "Development (1 error)


    even when i open a blank foundation project, and do absolutley nothing to it I still get this message

    keep in mind that i have forgotten almost everything i knew about programming and I am just starting to use XCode

    any help will be greatly appreciated and i thank you in advance
     
  2. Nutter macrumors 6502

    Joined:
    Mar 31, 2005
    Location:
    London, England
    #2
  3. Sayer macrumors 6502a

    Sayer

    Joined:
    Jan 4, 2002
    Location:
    Austin, TX
    #3
    You may have mistakenly copied over Xcode from somewhere, or somehow removed the underlying Unixy bits that do the actual compiling work for Xcode.

    There is a ton of stuff that must be installed behind the scenes to enable programming on OS X, much more than just Xcode.app.
     

Share This Page