Can't get Apple's Remote app working

Discussion in 'iOS Apps' started by aforty, Jul 12, 2008.

  1. aforty macrumors 65816


    Nov 27, 2007
    Brooklyn, NY
    Having major problems with this.

    In iTunes Preferences, I have "Look for iPhone & iPod touch Remotes" enabled.
    I have both the computer and the iPhone connected to the same WIFI network.

    I have iTunes running when I start the Remote app on my iPhone which gives me the code to enter in iTunes but I can't even see the Devices menu in iTunes so there is nothing to select.

    What am I doing wrong, any ideas?
  2. ChazDaSpaz macrumors regular

    Mar 16, 2008
    This method has worked for me:

    1) Open system preferences, go to security.

    2) Go to the 3rd menu - Firewall.

    3) There are 3 radio buttons, click the third one "Set access for specific services and applications"

    4) Near the bottom of the window there is a plus sign, click it and add iTunes to the list.

    Do that and you should be fine. Good luck!
  3. ogdogg macrumors 6502

    Jun 26, 2008
    I had the same problem. I unplugged my router and plugged it back in and everything worked perfectly. Haven't had any problems yet. I also added an Airport Express to my setup so now I can play music in any room in my house with my iPhone. This app has pretty much changed my life.
  4. aforty thread starter macrumors 65816


    Nov 27, 2007
    Brooklyn, NY
    That worked.

    I followed your steps to set it up, after I was done I set my firewall back to what it was (allow all) and the remote still worked.

    So all is good I think, thanks for the tip!
  5. manda386 macrumors newbie

    Jul 14, 2008
    i'm also having the same problem, but i'm afraid i'm having trouble following the steps outlined above. I unplugged my router and configured my mcafee firewall, but my iphone still isn't showing up in itunes. Any other advice? Thanks!
  6. Jager1726 macrumors newbie

    Jul 19, 2008
    I'm having the same problem - the iPhone Remote app can't find my library. The weird thing is that the problem is intermittent. Most of the time it doesn't work, but twice now I have been able to successfully connnect to and control iTunes through the iPhone. I just checked my firewall settings (which are managed through my virus protection software, not Windows, and iTunes is already allowed full access). Any other suggestions?
  7. steverhowells macrumors newbie

    Jan 9, 2009
    Remote does not work with latest McAfee Internet Security

    OK so.. where to start.. I have gone through everything but the summary is..

    I can get the iPhone to pair with iTunes no problem by adding the TCP and UDP ports to the firewall settings, both windows and McAfee, but then the iPhone just tells me that it cannot find the library.

    I made sure that all .exe related to iTunes were in the allowed list in McAfee and ensured that the services were correct, trusted my local area network AGAIN, and then added the specfiic IP addresses of my 2 devices and ensured that they would always get the same IP. NOTHING!!!!!

    Then I turned off the McAfee firewall and hey presto everything worked no bother...

    Now for the scary part......

    If I simply turn the firewall back no it remains working until I restart the application on the iPhone.... This to me highlights a huge security flaw in McAfee.. it does not reinforce settings once disabled and enabled, it allows every program that has been started in the interim period to continue operating!!!!!!!!!!!!!!

    Spent 2 hours with McAfee tech last night and they are clueless.. old re-install everything advice....

    Any ideas peeps????? :eek:
  8. frankiechan1 macrumors member

    Aug 20, 2008
  9. gotshoki Guest

    You'll need to check your Ip Settings, too.
    If your router accidentialy sets your Ipod's Ip in the wrong way it cannot work. Im using an iPod Touch 2G (3.0), iTunes on a Vista Computer.

    In examples:

    Computer Ip:
    Ipod/Phone Ip:

    When this kind of ip constellation occurs, you'll need to make at least one Ip Static to match the others first three numbers.


    Computer Ip:
    Ipod/Phone Ip:

    This or any other constellation can be used for your connection (notice the last number needs to be different for each Ip!). Also your Subnet Mask needs to match, they need to be the same (like

    Btw. You can always set your Computers Ip to a static one, you just need to know what Ip/Subnet Mask/Default Gateway/Preffered DNS Server codes your Router uses. You can easily find that out through watching at your automatically given adress format and then just use this for your static Ip, that is, of course, if you are using a Router to connect to the internet.
    (I recommend to always use a static Ip when using a Home Network + it will fix eventual Ip issues like the Remote App issue)

    Last but not least check your Firewall settings (iTunes should be allowed as well as remote services, I recommend to turn your firewall off for testing purposes though). Also check for other programs that might block incoming remote actions (like virus protection programs etc., eventually also turn them off for testing purposes)

    I hope even though my english is rubbish I was able to explain how the Remote App is most likely going to work from my experiences.
    Hope this helps... :)

    bye, shoki
  10. willemd macrumors newbie

    Sep 10, 2009
    Advice works well

    Thanks to all of those who posted solutions to the Iphone remote problem. I changed my security settings as described and my Iphone finally works as it should as a remote. The difference is astounding, and I cannot believe that the procedure outlined on this thread isn't standard reading when downloading this app. One thing--does the change in security settings have any negative consequences that one should be aware of?
  11. m4rkie23 macrumors member

    Jul 1, 2009
    ill give this a shot when i get in. still cant get mine to work.
  12. DEdwards2204 macrumors member


    Jun 16, 2009
    Charleston, West Virginia
    Thank you, Gotshoki. I made all remote services an exception and the application works fine now.
  13. padfoot20 macrumors newbie

    Mar 18, 2010
    For some reason I cannot get it to work.
    I am on the same wifi network, I have my security preferences set to allow itunes connections, I have enabled itunes to look for/allow remotes, and I have noticed my IP addresses to be the same except the last two digits are different.

    Does anyone have any suggestions? I think it may be with one of the items not being set to static? (But Im not using a router, Im connecting to my University's wireless network)
    I run a macbook pro with 10.6 snow leopard and the app is on my iphone 3g
  14. Birall macrumors newbie

    Oct 1, 2010
    Hey guys, I am having a similar problem which i can't seem to find any solution to. When I click on the Remote application it gives me the passcode, I then have the device appear in iTunes which I then type the passcode into, I wait about 15 seconds and it make a beep noise and nothing happens, not connection, the passcode on iTunes just goes blank again. Have tried all the router and firwall troubleshooting actions but nothing has worked yet.

    Any advice?
  15. jasewes macrumors newbie

    Oct 6, 2010
    Apple Remote application for Iphone

    Hi I have been struggling with the same problem for the last few days and after reading through/applying all the steps in the thread I still couldnt get the remote app to work. One thing I found though was that if I disabled the OSX firewall (allow all incoming services, the top option in system preferences/security/firewall) then my remote app could detect my itunes library. However I always have the firewall on and use the bottom option (allow selected incoming services, in system preferences/security/firewall). I then have I Tunes set in my firewall as a selected service. By removing I Tunes from my firewall and then trying to connect the remote application the problem was solved.. Hope this helps I know how frustrating this problem is..
  16. daveb macrumors newbie

    Jun 16, 2003
    Springfield, Oregon
    Same problems, no success

    I've got the same problem, and nothing seems to work. Initially it worked just fine, but now, nothing. The odd thing is that it worked just fine when we used all the same equipment (router, computers, iPhone, and iPod Touch) at my in-laws over the holidays. The only thing we changed is the location and the ISP. I didn't think that the communication would depend on actually getting to the internet, since it's on a local network. I'm stumped.
  17. Benito macrumors 6502a


    Jan 5, 2010
    Toronto, Canada
    I'm having problems getting the remote to work too. I recently got a new MBP, I transferred my settings etc. via Migration Assistant. Things went well for the most part. The only problem is that my iPhone4 can no longer control my iTunes library. It can still control my old computer's library though (I changed the name of the library on my old computer). In iTunes, I paired my iPhone to iTunes by entering the 4 digit number as instructed by the iPhone, yet even after doing that, I cannot connect to the library on my new computer. Any ideas?
  18. nhallahan macrumors newbie

    Feb 23, 2012
    iPhone remote app not working

    I read through this forum about two weeks ago and a lot of people had some of the symptoms that I had but none exactly the same. I have a MBP & TC ,iPhone 4s and apple tv and when I initially set it up everything worked fine remote app, Airport utility and mirroring. However one day it stopped working I didn't have a clue what was going on so I checked all the forums no solution however it began working again. A few days later the remote app wasn't working again ? I tried all the advanced features and everything mentioned on this forum none worked. Eventually I just spotted that on my iPhone I wasn't logging into my main time capsule network I was logging into my time capsule guest network. Problem solved switched back to my main network everything works great:D.
  19. camdenriley macrumors newbie

    Dec 7, 2012
    Not working at all!

    I have tried all the different things that you guys have all recommended, but I cannot seem to get ANYTHING to work and still can't get the remote to work.... I am using a Mac OX 10.6.8. I messed with the firewall and added iTunes to the list but that did nothing. Any ideas guys? Please help.... Thanks!

    If you know of anything please post a reply or something! Thanks!

Share This Page