Apple TV Can't get ATV 2G into DFU mode.

Discussion in 'Jailbreaks and iOS Hacks' started by jasonwilson88, Dec 26, 2010.

  1. jasonwilson88 macrumors newbie

    Jul 1, 2010
    Hey guys, by no means am I a jailbreak newb (been doing them since 2007) but this Apple TV is throwing me for a loop.

    I've created my custom bundle with pwnagetool so now I'm trying to get the thing into DFU mode.

    I only have the micro-usb cable connected into my Mac. When I first plug it in iTunes recognizes the Apple TV in regular mode and gives me the option to restore. I ignore that and continue on with the DFU mode instructions.

    I've tried following the prompts in pwnagetool and I've tried doing the menu+down for 6 seconds followed by the menu+play method and neither work.

    When I hold down either set of buttons after about 6 seconds it starts blinking but neither combo ever makes the ATV disappear from iTunes which makes me think it isn't even restarting.

    Any tips / tricks to help me get this thing into DFU mode would be GREATLY appreciated, this is so frustrating.

    EDIT: When I first set up my Apple TV yesterday it requested that I update it which I did, so it's sitting on the newest firmware. Does the newest firmware disable the menu+down and menu+play remote combos?
  2. Mattsasa macrumors 68020


    Apr 12, 2010
    i have been having the same problem, and it has been driving me crazy! I can't get it into dfu, i am also on 4.2.1.
  3. bensen macrumors newbie


    Jan 15, 2008
    dito, its a problem with the current pwnage tool version. so its not possible with 4.2.1 to put the apple tv into dfu mode.
  4. NOYB111 macrumors newbie

    Jan 5, 2011
    So is this definitely confirmed? You CANNOT put AppleTV in DFU mode running 4.2.1? I also just bought a new ATV and it came with 4.2.1 and I can get my customer ispw created, but I cannot get into DFU to install it. What confuses me is that I did it from directions at the link below which is stating 4.2.1 instructions???
  5. NOYB111 macrumors newbie

    Jan 5, 2011
    *** WRONG *** You CAN get in DFU on 4.2.1... I just did

    I just jailbroke my ATV 4.2.1 which was purchased on 1/5/11. It came with 4.2.1 on it.

    I followed the directions to make the custom firmware and was getting hung up trying to get into DFU. Problem is I was in DFU the entire time, its just that iTunes doesnt say it! When I would put it in DFU manually or with Pwnage and then fire up iTunes it would only show the option to 'restore' and not say it detected an AppleTV in DFU mode. BUT, but... once you are in iTunes, if you HOLD DOWN THE OPTION BUTTON on your MAC while clicking RESTORE in iTunes you can select the custom ISPW you created. I did, it worked, I jailbroke and SSH into it and added NitoTV.

    All directions in that link worked, just need to hold down the 'option' button while clicking 'restore'.
  6. pixelss macrumors member

    Feb 7, 2010
    I still get an error, have the same problem with my apple tv 2g, will not go in DFU mode
  7. bigdaddydavidp macrumors newbie

    Jan 8, 2011
    You can get it into DFU mode...

    ...and you can see it on the youtube video here:

    And if you have OS X 10.6 or greater go here:

    These are the silver bullets to jailbreaking 4.2.1 ATV on Mac with 10.6 or greater!

    I just cant get it to execute the tetheredboot command in terminal on 10.5.8

    Still trying the manual tethered boot with the instructions on applevtblogr as I am on 10.5.8 and cant use seas0npass.

    I am getting the now popular "unknown required load command" error when executing the ./tetheredboot command (see below) on my 10.5.8 MacBook Pro.

    ???? CAN ANYONE CONFIRM that this is because of 10.5.8 and that 10.6 or greater I can get the tetheredboot to execute? If so does anyone know how if I can execute the tetheredboot utility in the windows version and still send it the iBSS and kernelcache parms????


    My terminal session shows:

    deborahs-macbook-pro:~ deborah$ cp -r ~/Desktop/tethered/
    AppleTV2,1_4.2.1_8C154.bundle /Applications/
    deborahs-macbook-pro:~ deborah$ unzip -j ~/Desktop/tethered/
    AppleTV2,1_4.2.1_8C154_Custom_Restore.ipsw Firmware/dfu/
    iBSS.k66ap.RELEASE.dfu kernelcache.release.k66 -d ~/Desktop/tethered/
    Archive: /Users/deborah/Desktop/tethered/
    inflating: /Users/deborah/Desktop/tethered/iBSS.k66ap.RELEASE.dfu
    inflating: /Users/deborah/Desktop/tethered/kernelcache.release.k66
    deborahs-macbook-pro:~ deborah$ cd ~/desktop/tethered
    deborahs-macbook-pro:tethered deborah$ ./tetheredboot -i iBSS.k66ap.RELEASE.dfu -k kernelcache.release.k66
    dyld: unknown required load command 0x80000022
    Trace/BPT trap
    deborahs-macbook-pro:tethered deborah$
  8. roger06 macrumors newbie

    Sep 30, 2005
    Anyone had any joy with this ?

    I too have the same problem but am confused about 2 things.

    1) My ATV says it's software is up to date - but tells me it's 4.1.1 (not 4.2.1 as you guys are talking about)

    2) I can't get my ATV to mount in iTunes at all when I plug in the USB cable. iTunes doesn't even open but I get a flashing light on the ATV.

    I've made a 'custom' firmware file so I'm sure I could install this if I could mount it in iTunes...

  9. rgarjr macrumors 603


    Apr 2, 2009
    Southern California
    The ATV2 will say it's on 4.1.1 but if you press the center button a few times it will switch to 4.2.1. Some type of glitch I think.
  10. The Mad Hatter macrumors 6502a

    The Mad Hatter

    Oct 12, 2004
    Well I finally got mine into DFU and JB'n, after not getting into DFU (via pwnage), and getting an error 21 from iTunes. This was on a brand-spanking new one from Amazon.

    I think the key for me was restoring it with the unchanged FW (4.2.1 in my case). Then hooking/setting it up normally (ie. turning on Home Sharing, partially playing a vid, etc.) Then I put it to sleep, and disconnected it. Low and behold, I was able to get it into DFU via pwnage 4.2. Then I did the custom restore in iTunes, and now all is golden.

    Hope this helps.
  11. tom1971 macrumors 6502a

    May 15, 2007
  12. toreolav macrumors newbie

    Jul 31, 2012
    I am having trouble get the Apple TV 2gen into DFU mode too.
    This has worked without any major problems before, but this time it just wont get into DFU mode. I am now jailbreaking the last firmware, iOS 5.0.2, to get thr airplay mirroring to work. I have been reading all over the web and tried all sorts of tricks, without any luck.

    The only thing that is different from before, is the mac I am running seasonpass on and that I now only have a Logitech Harmony remote.
    I am now running seasonpass on a Macbook Pro Retina. I cant see how this could cause any problems though. I have jailbreaked my apple tv with the same usb cable before, so I dont think that is the problem either?

    Only thing I am worried about is the Harmony remote, do I have to use the original silver remote? This was stolen, so I dont have this available.

    Does it work to jailbreak with a Harmony remote? Haven`t got any real answers to this anywhere.

    All help is highly appreciated.
  13. mervey macrumors newbie

    Mar 6, 2013
    i found it here, i'm shareing with you, it is possible to jailbreak an AppleTv 2 even if you’ve lost the Silver Remote.

    1) Download the latest version of Redsn0w from

    2) Download the latest version of iOS firmware, even if you are not planning on using this version of firmware.

    3) Extract Redsn0w then open it.

    4) Click on Extras.

    4) Click on Even More.

    5) Click on DFU IPSW.

    6) Click on OK.

    7) Find your Firmware File and Click Open.

    8) Wait for the process to finish creating the new IPSW file.

    9) When done you will see the message IPSW created.

    10) You can now use this firmware file to put the AppleTV into DFU mode.

    11) Connect the AppleTV to your computer. Restore the newly created IPSW in iTunes. It will fail with an error, this is normal. Your AppleTv 2 is not in DFU mode. You may now use Seas0nPass to Jailbreak your AppleTv as usual, but when it get’s to the point where you put it into DFU mode, it will already detect an AppleTv in DFU mode and start the Jailbreak.

Share This Page