Can't get home share to work

Discussion in 'Apple TV and Home Theater' started by exhibit.b, Dec 25, 2010.

  1. exhibit.b macrumors regular

    Joined:
    Jul 11, 2008
    #1
    I have been trying for days and I just can't get it to work between my apple tv and computer, or between my iphone and computer but it works fine between the apple tv and iphone. Can anyone tell me how to fix this? I am running windows 7. I thought it might be a problem with my router (Belkin share n300) but i dont why it would would work with the apple tv and iphone though.
    Any help is greatly appreciated.
     
  2. cadillac1234 macrumors regular

    Joined:
    Aug 20, 2010
    #2
    Is the router capable or running simultaneous dual bands?

    If so check to see if the Apple TV and your other devices are all on the same band
     
  3. exhibit.b thread starter macrumors regular

    Joined:
    Jul 11, 2008
  4. scottdot macrumors member

    scottdot

    Joined:
    Dec 29, 2008
    Location:
    New Mexico
    #4
    I ran into a similar problem I'm still investigating. My Apple TV worked great with Home Sharing running on two separate Macs, and I could use Remote.app on my iPod Touch. Then one day out of the blue, none of them are talking anymore. I'm still using the same router I started with. If I remember correctly, my Apple TV downloaded the most recent software update about a week before Christmas and it continued to work for a while after that.
     
  5. Cmu93 macrumors member

    Joined:
    Dec 4, 2007
    Location:
    Michigan
    #5
    Had the same issue this morning. All I did was turn off the Home Sharing on my Win7 PC and then turn it back on again, and then Atv found it no problem.

    Tom
     
  6. zbarsky, Dec 27, 2010
    Last edited: Dec 27, 2010

    zbarsky macrumors newbie

    Joined:
    Aug 19, 2007
    #6
    Getting home sharing to work seems like black magic. I've spent 5 hours over the past 3 days contending with it. Seems like it's an evil mix of router settings, firewall settings, router type, bonjour issues, network card drivers, wi-fi channels to consider - if you are are on the PC side of things. I think installing an updated driver for my onboard network interface did it for me in the end which enabled the bonjour service.
     

Share This Page