Can't get into the SSH.

Discussion in 'Jailbreaks and iOS Hacks' started by TMac93, Aug 1, 2008.

  1. TMac93 macrumors member

    Joined:
    Apr 20, 2008
    #1
    I have a jailbroken iPhone 3G, and I've been trying to get into the SSH using WinSCP, but whenever I log in, I get the "Network error: Connection timed out"

    I'm doing everything right, I know I am.

    I read somewhere that I should see if I can ping the iPhone so I go

    Run
    ping (IP address)

    After trying to ping my IP address, eventually it just says "Request timed out"

    Is that adding to the problem?

    How do I fix it?

    Please help!
     
  2. Namikaze macrumors member

    Joined:
    Jul 21, 2008
  3. mac2thefuture macrumors 65816

    Joined:
    May 15, 2007
    Location:
    Lancashire, North West, UK
    #3
    My SSH disappeared when I updated my Jail broken version 1 phone to the new update:confused::confused::confused:
     
  4. Speedracer04 macrumors 6502a

    Speedracer04

    Joined:
    Sep 8, 2006
    Location:
    Michigan
    #4
    I had this problem for a long time with my old 2g iPhone...

    But I recently figured out how to make it work. Im on a mac, but I was trying to use cyberduck but it kept timing out. Up until a few days ago I hadnt tried to go directly through terminal first, but once I did it worked!

    Go into terminal and type ssh @rootXXX.XXX.X.XXX, let it sit for a few minutes to generate the passwords and stuff...then try and go through cyberduck or w/e SFTP client and configure it.
     
  5. The General macrumors 601

    Joined:
    Jul 7, 2006
    #5
    No, it's ssh root@xxx.xxx.xxx.xxx
     
  6. walturbo macrumors newbie

    Joined:
    Dec 22, 2004
    #6
    can't input password

    When I use terminal it asks for a password but I can't input any info. It logs in to IP then asks for password but freezes. I'm trying to fix mail crash on 2.0 with Cydia installed
     
  7. dancavallaro macrumors regular

    Joined:
    Jul 13, 2008
    #7
    It's not frozen - nothing will show up when you type in your password. Just type it in, and press enter and it should work.
     
  8. JClarkKent2003 macrumors newbie

    Joined:
    Dec 25, 2008
    #8
    did anyone learn how to fix this?

    I'm still unable to get in via SSH.

    I'm doing everything right, I even installed open ssh and SBboard tools via cydia, they are running but it refuses the connection, pinging works.
     

Share This Page