Can't get iOS email push/fetch to work

Discussion in 'iOS 10' started by lsutigerfan1976, Feb 15, 2017.

  1. lsutigerfan1976 macrumors 68000

    Joined:
    Sep 14, 2012
    #1
    I tried 3 different email addresses. One is a yahoo email, one is gmail, one is aol. None of the three seem to push or fetch my email. Only time I can get it to refresh and show new emails is when I go inside the app and refresh it manually. I tried resetting the network settings. I tried reinstalling my iOS. I removed and added my email plenty of times. But to no avail. I cannot get the iOS email app to work at all. And I have push turned on, plus I have it set to fetch every 15 minutes. Nothing. Any suggestions?
     
  2. niceandeasy macrumors member

    niceandeasy

    Joined:
    Feb 14, 2017
    #2
    Are your yahoo, gmail and aol accounts set up with push activated? I think you need to enable it on the account itself as well as within settings on your iPhone.
     
  3. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #3
    On the account where? iOS will basically know if the account is capable of push or not, and even without push the fetch should still work.
     
  4. lsutigerfan1976 thread starter macrumors 68000

    Joined:
    Sep 14, 2012
    #4
    How do I check that? Everything worked fine till like two weeks ago. Before that I got my emails pushed just fine. Now they don't come up, even if I set the app to fetch them every 15 minutes. And I didn't make any changes recently.
     
  5. Rhonindk macrumors 68020

    Rhonindk

    Joined:
    Oct 3, 2014
    Location:
    Bloom County: Meadow Party
    #5
    Had that issue when I updated to 10.2.1. I have 4 Fetch and 2 Push. The push continued to work but the Fetch failed unless I did them manually. I ended up having to remove the Fetch, reinstall the fetch and let the accounts resync. They appear to be working okay. I say that tongue in cheek as I occasionally see a mismatch between that and mu Polymail (free version) account for the push.

    Worked fine under 10.2.0
     
  6. lsutigerfan1976 thread starter macrumors 68000

    Joined:
    Sep 14, 2012
    #6
    I am still having issues. Tried removing email accounts, adding again, removing mail app adding it back. Resetting all the settings. Even wiping my phone. It seems to be an issue with the iOS email app. As when I download the yahoo/gmail etc apps they work fine. But the iOS app doesn't work for me, unless I manually fetch the emails. I about gave up trying to find a fix for the iOS email app. Unless anyone else has any other ideas.
     
  7. Rhonindk macrumors 68020

    Rhonindk

    Joined:
    Oct 3, 2014
    Location:
    Bloom County: Meadow Party
    #7
    Been playing around with Airmail first and now Polymail. Apple email iOS doesn't work as well as it did.
     
  8. perezr10 macrumors 6502a

    Joined:
    Jan 12, 2014
    Location:
    Monroe, Louisiana
    #8
    I think it's an Apple problem. I'm having the same issue. I don't get e-mails unless I actually open e-mail. I thought it was because I was on beta 10.3. I didn't realize this was happening elsewhere.
     
  9. JacobF macrumors newbie

    Joined:
    Oct 26, 2016
    #9
    I'm having the same problem. It started after I updated to iOS 10.2.1 although I'm not sure if it started immediately after updating.
     

Share This Page