Can't get multiple Google calendars to sync (iPhone 5)

Discussion in 'iPhone Tips, Help and Troubleshooting' started by phositadc, Dec 11, 2012.

  1. phositadc macrumors 6502

    Joined:
    Dec 9, 2012
    #1
    Long time Android user bought an iPhone 5 last night. Having serious trouble getting shared Google calendars to display.

    I have my Google account set up as Exchange. That seemed to go through smoothly and my main Google calendar shows up just fine. I then went to https://www.google.com/calendar/iphoneselect and all of my calendars appear. I put checkboxes in the ones I wanted to sync to my iPhone, but they did not show up in my iPhone Calendar app. Waited and waited, never showed up.

    I even deleted my Exchange account completely and re-added it. Still, only the primary calendar shows up in Exchange.

    Any help would be greatly appreciated.

    Edit: Oh, and I've been to that iphoneselect website from both my iPhone using the Safari browser, and from my computer using Chrome browser, and both browsers show the calendars I want to sync as having check marks in the boxes. Those calendars simply do not sync. Is there possibly some issue with Google not being aware that I have an iPhone since I had an Android for so long?

    If I go to m.google.com/sync from my iPhone browser, it does not show up with a device select page. It just shows up with a generic Google sync page, where I can click a "Calendar" icon, then choose "Sync with a mobile device," then choose "Apple device" and it takes me to a settings page that ultimately leads me to the same check box webpage as https://www.google.com/calendar/iphoneselect. Which, as I said, already shows check marks in the calendars that I want.
     
  2. phositadc thread starter macrumors 6502

    Joined:
    Dec 9, 2012
    #2
    FYI I finally got it to work. Had to read this thread: https://discussions.apple.com/thread/4310898?start=45&tstart=0 and then follow the instructions of using Safari Browser, setting User Agent to iPhone, browsing to https://m.google.com/sync/settings/iconfig/, and then proceeding from there.

    It seems that going to m.google.com/sync no longer allows you to setup shared Google calendars for Exchange anymore -- only for CalDAV. Disappointing, but at least the method described in the above link works fine -- even if a little bit hard to discover for a new iPhone user.
     
  3. joeyconnick macrumors newbie

    Joined:
    Mar 10, 2007
    #3
    Thank you SO Much for this URL... I kept trying to go to http://m.google.com/sync and they've changed it, I guess because they're assuming everyone is going to be using CalDAV soon, not Exchange ActiveSync.
     

Share This Page