Cant get my imac to start after power trip

Discussion in 'iMac' started by pecchi17, Oct 16, 2012.

  1. pecchi17 macrumors newbie

    Joined:
    Oct 16, 2012
    #1
    hi All,

    new to the boards and in desperate need of some guidance.

    After having an electrical trip in the house earlier on i went to go and turn on my 27" iMac - around 4 years old. When i pressed the power button nothing happened. So i thought it might be the extension cable i was using that had a problem.

    Unfortunately its not and everything else plugged into it works fine.

    literally nothing is happening when i press on the power.

    I have tried looking up various forums and similar situations have come up but none exactly the same. Im really struggling and really need to good news.

    can anyone suggest anything?

    J
     
  2. pecchi17 thread starter macrumors newbie

    Joined:
    Oct 16, 2012
    #2
    Any idea's anyone? or is it back to the shop for inspection?

    any guidance would be great
     
  3. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
  4. triweaver2 macrumors newbie

    Joined:
    Jun 22, 2012
    #4
    If on a surge supressor, try turning that off then back on. Seems to work for my 2008 iMac which has had this problem for years. I replaced the supressor and still had issues.

    Come on new models!
     
  5. ivbaseball06 macrumors member

    Joined:
    Nov 20, 2010
    #5
    My early 2006 does this after losing power. Unplug the power cord from the wall and the computer both. Hold the power button down for about 10 seconds while unplugged and then leave it be. Come back in about an hour and plug it in. See if it will start then. Mine always does after doing this. (Also maybe try another outlet)
     
  6. pecchi17 thread starter macrumors newbie

    Joined:
    Oct 16, 2012
    #6
    thanks guys,

    I'm going to take a power cable from work to see if it makes a difference. if not i will try like you suggested and unplug, keep finger on power button for 10 secs and leave for a while and try again.

    Is it to the apple store after that if it does't work?

    Any idea's how much it would cost - if i need to go to the apple store with it?

    J
     
  7. ivbaseball06 macrumors member

    Joined:
    Nov 20, 2010
    #7
    I would definitely try my method before anything else. Mine does the exact same thing and that fixes it every time. I think it has something to do with draining the capacitors and then letting them fill back up again fresh. I really think it would work for you.

    As far as the Apple Store goes, odds are it's going to be the power cord or the power supply. Maybe logic board if you fried something. If my method doesn't work, it doesn't hurt to take it in and see if they can figure it out before having to even write you a quote. Cord and power supply wouldn't be crazy, both probably under $200. Logic board gets expensive.

    Source: I've gone through all of these steps. Ended up not replacing anything because I figured out how to get it back on each time.
     
  8. Yamcha macrumors 68000

    Joined:
    Mar 6, 2008
    #8
    Did you try on a different wall socket? I've had instances where the wall socket would no longer work after power trip..
     
  9. pecchi17 thread starter macrumors newbie

    Joined:
    Oct 16, 2012
    #9
    the plug socket still seems ok as there is an extension cable in the same socket and my lamp is working.

    i have tried pressing the power button for 10 seconds with everything unplugged so i will try it in a new socket with the power cable taken from a mac in work.

    fingers crossed. any other ideas?

    J
     
  10. pecchi17 thread starter macrumors newbie

    Joined:
    Oct 16, 2012
    #10
    Looks like I need to take it to a repair shop. Going to see what the local repair shops say before taking it into apple.

    I'm just hoping I won't lose all my files as its been quite a while since my last back up.
     

Share This Page