Can't Get My MX-518 Mouse Buttons To Work...

Discussion in 'Mac Basics and Help' started by DrYou, May 26, 2008.

  1. DrYou macrumors newbie

    Joined:
    Apr 3, 2008
    #1
    I've already read a ton of threads on this mouse which all say that USB overdrive or SteerMouse will allow me to use the extra buttons on the MX518, but there not working. I'm a recent PC switcher, so I'm new to Mac's but am IT at my company so I'm not computer retarded. The only thing I could think that might have caused some issues is that before I bought the MX518 I had a M$8000 mouse which also didn't work, but no one has had luck getting that one working. In the process of trying to get the M$8000 to work I probably installed and uninstalled IntelliPoint 20+ times and USBOD and SteerMouse about 5-10 times each. Sometimes I’d use the Uninstaller and sometimes I’d AppZap it, and in trying to get the MX518 to work I’ve also Installed USBOD and SteerMouse another 10 times probably. That being said, could that have cause my issues?

    BTW, I'm running a newer Intel 2.4 Macbook


    Thanks for the help, Dru.


    -{edited to correct spelling}
     
  2. DrYou thread starter macrumors newbie

    Joined:
    Apr 3, 2008
  3. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #3
    So you didn't start off with the Logitech Control Center for OS X?
     
  4. IMcD23 macrumors regular

    IMcD23

    Joined:
    Aug 4, 2007
    Location:
    Iowa, United States, Earth, Milky Way, . . .
  5. G-Force macrumors 6502a

    Joined:
    Nov 25, 2006
    #5
    As far as I know, it does not support the MX518. The mouse buttons will not work anymore after installing it.

    I've purchased USB Overdrive for my MX518, works great. Steermouse also works great. :)
     
  6. DrYou thread starter macrumors newbie

    Joined:
    Apr 3, 2008
    #6
    I've tried Logitech Control Center even though it doesn't support the MX518. Like I said in my post, USBODrive and SteerMouse aren't working either.

    I still think it has something to do with me installing and uninstalling all those times... Any other suggestions?
     
  7. DrYou thread starter macrumors newbie

    Joined:
    Apr 3, 2008
    #7
    Well a little update. After installing 10.5.3, USB Overdrive is working with the MX518. Not sure why this happened, but all is now well in DrYouLand.

    Thanks
     

Share This Page