Can't get my WiFi working

Discussion in 'iPhone Tips, Help and Troubleshooting' started by SeanPof, Mar 29, 2008.

  1. SeanPof macrumors newbie

    Joined:
    Mar 29, 2008
    #1
    Hello,

    I'm having severe problems with my WiFi, I can't get it to work on neither the 1.1.2, 1.1.3 or 1.1.4 firmware.
    It always recognizes the networks in the area, but I get the message 'unable to connect to network' or when I get connected, I don't get assigned an IP, or I just get the 169.254.x.x IP.
    At first I thought it was my own router that gave the problems, but I've been to like 6-7 people with wireless routers, just to test it out, and I always get the same problems. A friend of mine has an Iphone also, and he connects easily to every network.
    I've tried to fill in the static ip thing, but just nothing works. And I don't think my WiFi is broken cause I do see all the networks, and from time to time I do get connected (without getting the right ip settings though). I'm really getting desperate, cause I've got the feeling I've tried everything around.

    Greetz
     
  2. misaje macrumors newbie

    misaje

    Joined:
    Mar 29, 2008
    #2
    I may have fixed it................................

    What i did was to reset the Network settings

    Go Settings/General/Reset/Reset Network Settings

    Also changed Auto-Lock Never

    Let me know if it works :D
     

Share This Page