Cant get Netflix to work on my MBP

Discussion in 'MacBook Pro' started by jrm27, Aug 25, 2013.

  1. jrm27 macrumors 6502

    Joined:
    Jan 3, 2008
    #1
    Hello all,

    I've been trying for weeks now to get Netflix up and running on my MBP. every time I try and get it running I get an error. Error 2104 telling me that I need to uninstall silverlight and try again. I've done this maybe 15 times now... and I've deleted every trace of silverlight from my computer in order to get clean installs of it. No dice. Anyone else able to get it working and have any ideas?

    I contacted Netflix, they walked me through uninstalling (again) and then told me to get in touch with microsoft. No response from msft.

    so... is there no way I can watch netflix now?
     
  2. tmagman macrumors 6502

    Joined:
    Nov 7, 2010
    Location:
    Calgary AB
    #2
    what web browser are you using? Try another browser like firefox (netflix is the only thing I use it for). I had this problem and that seemed to work.
     
  3. Laco macrumors 6502

    Joined:
    Apr 23, 2008
    #3
    How old is your macbook? My previous Macbook that I bought six years ago could you not handle Netflix and Silverlight. Since I upgrade last year to a 13 Macbook Pro I have no problems at all.
     
  4. jrs22 macrumors 6502

    Joined:
    Aug 1, 2012
    #4
    Silverlight is a plug-in. I have a recent MBP with Mountain Lion and I had to go into Safari preferences to enable them before the download and install worked.
     
  5. Count Blah macrumors 68030

    Count Blah

    Joined:
    Jan 6, 2004
    Location:
    US of A
    #5
    As suggested, use a different browser. On an old 2008 iMac, I can get netflix to work on safari and Chrome, but it refuses to work on firefox.
     
  6. Breitling65 macrumors 6502

    Joined:
    Mar 3, 2011
    #6


    Works on mine 2013 MBPR, initially after installing Silverlight only on Chrome but after I restart laptop it works on Safari too.
     
  7. jrm27 thread starter macrumors 6502

    Joined:
    Jan 3, 2008
    #7
    It's the current generation mbp, and ive tried both Firefox and safari. Guess ill give chrome a try next?
     
  8. Aylan macrumors regular

    Aylan

    Joined:
    Jun 3, 2013
    Location:
    Boston
    #8
    I was having this issue too after I restored a Time Machine backup. I was also trying to play on an external monitor but not sure if that was the culprit. I was able to get mine to work again by logging out of Netflix, completely deleting Silverlight, clearing all my cookies/website data from all browsers, and re-installing Silverlight. I am sure that there is a way to only delete Netflix data but I did not want to bother looking for it.
     
  9. jrm27 thread starter macrumors 6502

    Joined:
    Jan 3, 2008
    #9
    Well, I tried that too... still not working. awesome.
     

Share This Page