Can't get new wireless printer to find network.

Discussion in 'macOS' started by russcolban, Jun 5, 2009.

  1. russcolban macrumors newbie

    Joined:
    Jun 5, 2009
    #1
    First, I'm an amateur at this stuff, so please be gentle.

    I've been trying all day to get my new wireless printer to find my wireless network. No joy.

    I have an airport extreme router connected to an AT&T 2WIRE modem. The guys that installed the AT&T stuff recently said I normally wouldn't need the airport extreme because the 2WIRE serves as both modem and router, however it does not work with an airport express, which I have in another room to boost the signal. So when the printer looks for the (SSID) network, it sees my apple network, which is what my macbook and windows vista laptops also see and connect to. After that, I'm entering the wireless network key from the 2WIRE.

    I've tried several (many) other configurations, numbers, etc. without success. Any ideas?

    Thanks.
     
  2. eawmp1 macrumors 601

    eawmp1

    Joined:
    Feb 19, 2008
    Location:
    FL
    #2
    I'm confused. If the printer sees your Apple network, which is what your laptops are connected to, what is the problem? Your notebooks should be able to print to the wireless printer on the Apple network Is there another computer (e.g. desktop that is hard wired to the 2WIRE) that is the problem?
     
  3. robert05au macrumors regular

    robert05au

    Joined:
    May 19, 2005
    Location:
    Dubbo, NSW
    #4
    One maybe silly question

    Are you running the wireless network as an 'n' (5 GHz) or bg (2.4 Ghz)?

    The printer may only be able to use a bg compatible network setup as the airport extreme can be use as either a bg or n compatible device.

    Any other info about how the network is setup this can be found under wireless tab in the airport utility and manual setup of the airport screen.

    I can help further sort this out as I use a printer wirelessly and had some similar issues myself.
     
  4. russcolban thread starter macrumors newbie

    Joined:
    Jun 5, 2009
    #5
    Thanks for the feedback.

    An early step in the printer setup is when it searches for an SSID. It's at this point it sees my airport extreme network, but it's not yet connected. When I subsequently complete the rest of the steps, I get a 'connection failed'.

    My airport extreme is wireless n, and the printer is wireless b/g, but isn't the airport extreme backward compatible?

    We have an MBP and a windows vista laptop connected to my airport extreme network. I thought for a while that since the 2WIRE is supposed to be both a modem and wireless router (according to the AT&T guys) that it might be somehow competing with the airport extreme and confusing the printer, but there's no sign of that happening with the laptop connections so apparently tht's not an issue.

    When setting up the printer I do the following:

    1 menu
    2 network
    3 wired LAN
    wlan
    network I/F
    factory reset
    I select wlan
    4 TCP/IP
    setup wizard
    SES/WPS/AOSS
    WPS w/PIN code
    wlan status
    I select setup wizard. the printer then searches for an SSID
    5 halfpastfive (this is my airport extreme network)
    GTSS
    dlink
    Bisek main
    new SSID
    I select halfpastfive
    6 Open system
    Shared key
    WPA/WPA2 - PSK
    I select WPA/WPA2 - PSK
    7 TKIP
    AES
    I select TKIP
    8 Then it shows WPA with an open block into which I have to enter a number. I've tried several, including my airport network number, the SSId number from the 2WIRE, the WEP key number from the 2Wire, the street number from my grandma's house -- just about everything.

    9 Apply Settings
    So I select 'yes', it searches while showing a 'connecting LAN' window, then a 'connection failed'.

    Does anyone have any ideas? I'm just about out of gas on this one.

    Russ
     
  5. cube macrumors G5

    Joined:
    May 10, 2004
    #6
    I don't know about the Airport configuration, but in any case, an access point must be set to 'mixed N', not 'N only', for the network to also work with non-N devices.
     
  6. russcolban thread starter macrumors newbie

    Joined:
    Jun 5, 2009
    #7
    Thanks cube. The windows laptop (emachine) is 802.11b/g and it works fine on the network so I guess the airport is in the correct mode.

    Russ
     
  7. mackmgg macrumors 65816

    mackmgg

    Joined:
    Nov 2, 2007
    #8
    What do you have to type in on you laptop in order to connect to the network? If you cannot guess it, I would just try to use ethernet (Wired LAN)
     
  8. cube macrumors G5

    Joined:
    May 10, 2004
    #9
    You have to enter the same parameters as in the other machines, including protocol (eg, WPA), encription (eg, AES), key (256-bit for WPA, typically in hexadecimal).
     
  9. russcolban thread starter macrumors newbie

    Joined:
    Jun 5, 2009
    #10
    Yes, my network access password was one of the many entries I tried.

    I also tried running a USB cable from the printer to the airport extreme. Interestingly, when I did this the MBP could connect to the printer, but the emachine laptop (Vista Home Basic) could not. When I spoke to the printer tech support folks they said the emachine would not connect in this configuration.

    Thanks for taking a stab at this. I'll probably end up returning the printer, but I'm wondering if this problem won't come up again whichever printer I buy so I wanted to give this one my best shot.

    Russ
     
  10. cube macrumors G5

    Joined:
    May 10, 2004
    #11
    Doesn't the printer come with a wizard program so that you can wire the printer and set up the wireless from the computer?
     
  11. russcolban thread starter macrumors newbie

    Joined:
    Jun 5, 2009
    #12
    Thanks cube. Yes, this is where I get a bit confused. I don't recall entering any of that data for the other machines when I set them up -- they just found the network and I followed the prompts to set them up.

    The way I understand it, the SSID is my network name -- in this case 'halfpastfive -- which the printer can see when it searches. But I did rename the network from the original letter and numbers, so I've tried entering one or the other at various times.

    I have a WEP key number, which I understand to be the wireless network key, but I'm not sure if my network is considered 'open' or 'shared'. And where exactly do I get the WPA numbers?

    I did try hooking up the laptop to the printer via USB and setting it up that way. It all works, but only gives me the option for a setup with USB and nothing for switching back over to wireless afterwards.

    Thanks for hanging in there.

    Russ
     
  12. cube macrumors G5

    Joined:
    May 10, 2004
    #13
    It seems you selected WPA and you have a WEP network.

    WEP has been crackable for a long time. Maybe it's still better to move to WPA.
     
  13. russcolban thread starter macrumors newbie

    Joined:
    Jun 5, 2009
    #14
    Eureka! Got the little bugger to connect. I'd been using the TKIP option on the advice of the AT&T guy, when I should have been using AES. The airport extreme network is WPA, but the 2WIRE had a WEP key number so I was a bit muddled about that too, but I was pretty sure I should be using the WPA password since the network was coming from the airport extreme and not the 2WIRE.

    Thanks for your feedback cube, and others. This is the first time I've used this forum and your drama free help is appreciated.

    Russ
     
  14. cube macrumors G5

    Joined:
    May 10, 2004
    #15
    TKIP is now crackable. It's better to use AES, like you're doing.

    I would disable the wireless on the 2WIRE.
     

Share This Page