Can't Get On Internet!! HELP!!

Discussion in 'MacBook Air' started by davekarn, Apr 23, 2009.

  1. davekarn macrumors 6502

    Joined:
    Jul 27, 2007
    #1
    Hey guys, yesterday in class I was able to access the internet fine, but something happened in the course of the day that no longer allowed me to access the internet. I figured that it was just the wifi on campus that was out of whack and didn't fret until I got home and the same thing was occurring. Airport is evidently working fine, as it is picking up the router, however it says something along the lines that a single IP address is being used and can't access the internet. I'm well outside my 90-days of complimentary calls to Apple and live to far away to travel to one. Has anyone had any experience with this and if so care to share advice? Thanks in advance!

    ~Dave
     
  2. Peace macrumors Core

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #2
    How did you make that post if you can't get online ?

    How is the computer in question connected to the internet?

    What kind of router? What kind of internet connection ? Cable ?, DSL? modem?
     
  3. davekarn thread starter macrumors 6502

    Joined:
    Jul 27, 2007
    #3
    I'm on my iMac at home. The router is an Airport Express and has been working fine with the iMac and my iPhone. Internet is cable through Time Warner, but obviously that is working fine too, as I am on right now. It's definitely something to do with the MBA...just don't know what went wrong, and why it crapped out.
     
  4. supernet33 macrumors regular

    Joined:
    Jan 29, 2008
    #4
    Try and call apple, they might help you out.. never know?

    Also

    Did you enable a static ip address?
     
  5. Peace macrumors Core

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #5
    Are you using DHCP on the router? If so what address range?

    10.0.1.2-10.0.1.100 ?

    169.172.* ?

    Use your airport utility to look at the router and make sure the DHCP is correctly done. It could be the Air needs to have the DHCP license renewed because the IP address assigned to it is being used by a different computer.
     
  6. davekarn thread starter macrumors 6502

    Joined:
    Jul 27, 2007
    #6
    Yeah, I'll try and give them a call, and would I know if I enabled a static ip address?? Lol, cause I have no clue.
     
  7. supernet33 macrumors regular

    Joined:
    Jan 29, 2008
    #7
  8. davekarn thread starter macrumors 6502

    Joined:
    Jul 27, 2007
    #8
  9. supernet33 macrumors regular

    Joined:
    Jan 29, 2008
    #9
    Stupid question, did you restart your computer?

    also i was going to IM you on AIM but i didn't see you on..
     
  10. Peace macrumors Core

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #10
    Open your Airport Utility.

    Select the Airport.

    Select the Internet Icon.

    Make sure the airport has an IP address and domain name servers.

    Click on Renew DHCP License.
     

    Attached Files:

  11. stoconnell macrumors 6502

    Joined:
    Mar 22, 2009
    Location:
    Rockville (Despite REM's plea.)
    #11
    Have you turned off the airport and turned it back on?


    Go to network preferences > advanced > tcp/ip

    And where it says: Configure IPv4, choose "Using DHCP" and make sure you hit OK and then Apply.
     
  12. davekarn thread starter macrumors 6502

    Joined:
    Jul 27, 2007
    #12
    Yeah I tried that while on hold with Apple, but didn't work, however I did get the solution! They transferred me to software to take care of it, but I will post what I did just so that other people who may get this problem know what to do. She said that it had something to do with the network that corrupted some files within Airport. Here is a step-by-step:

    1) Double-click on the Macintosh HD symbol to access the hard drive
    2) Click on the "Library" Folder
    3) Click on the "Preferences" Folder
    4) Click on the "SystemConfiguration" Folder
    5) Drag "com.apple.airport.preference.plist" to the trash (this will prompt for a password to verify on all 3 of these).
    6) Drag "com.apple.network.identification.plist" to the trash
    7) Drag "NetworkInterfaces.plist" to the trash
    8) Empty your trash
    9) Restart your computer
    10) Go to your Network Preferences via System Preferences
    11) Click on the "Location" pull down menu and select "Edit Location"
    12) Click on the plus sign and name your location and then click done
    13) Back on the Network Preferences, make sure Airport is selected on the left and then click Apply on the bottom right-hand corner.
    14) After a second or so, everything should be good!

    Thanks for all the input too!

    ~Dave
     

Share This Page