Can't Get Onto Certain Websites?

Discussion in 'MacBook Pro' started by Infl8edEg0, Aug 7, 2012.

  1. Infl8edEg0 macrumors newbie

    Joined:
    Mar 20, 2012
    #1
    Hey guys, I recently got a rMBP, and everything was working fine until I think when I installed Mountain Lion. All of a sudden, I can't connect to certain websites. So far the only ones I know of are Facebook and the Apple website. I can connect briefly if I go on a private browsing mode in any of the browsers I use, but I usually can't look at my profile or switch to the Page I'm a admin for on Facebook. I can go on if I boot into Windows instead, and all the other laptops in my house work.

    I've tried using openDNS, flushing the DNS, and clearing the cache and cookies. Any other ideas?

    Thanks

    I don't know if it's related, but I just found out it can't post anything on these forums either.
     
  2. geoffreak macrumors 68020

    geoffreak

    Joined:
    Feb 8, 2008
    #2
    I'm assuming you haven't done a fresh install of ML since upgrading from Lion? So many users are reporting issues that stem from this that I would recommend reinstalling fresh.
     
  3. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #3
    If you haven't already done so, try changing your DNS servers on your Mac and your router to OpenDNS servers. Make sure you've removed any other DNS servers that may be listed. This will show you how: Why am I being redirected to other sites?

    Also, check ad-blockers or extensions that may be interfering.
     
  4. Infl8edEg0 thread starter macrumors newbie

    Joined:
    Mar 20, 2012
    #4
    I haven't, but I just found out about an interesting feature called Archive and Install. I was hesitant to do a clean install before because I have a lot of files and programs, but if I do it this way all of my files and programs will be kept?

    Tried it, didn't work unfortunately. Thanks though!
     
  5. Infl8edEg0 thread starter macrumors newbie

    Joined:
    Mar 20, 2012
    #5
    I found a solution I'm pretty sure. I was getting really frustrated, a lot of websites were slow, or straight up wouldn't load. I tried the whole DNS thing, cleaned my cache, like I said before. I also tried a clean install of Mountain Lion, which also didn't fix anything. What did work was changing the MTU from 1500 to 1400 (I remembered reading this at one point, and figured why not?).

    In Mountain Lion it's System Preferences --> Network --> Advanced --> Hardware --> Change "Automatically" to "Manually", and change the value to 1400.

    For some reason this worked. I don't care why but it did. I can post on these forums now, go onto Apple's website, Facebook, everything.

    Thanks guys!
     

Share This Page