Can't get onto Frozen THrone Battle.net

Discussion in 'Mac and PC Games' started by Camtron, May 8, 2009.

  1. Camtron macrumors newbie

    Joined:
    Jan 6, 2009
    #1
    Hi,
    I have a dual 1.8 G5

    One day after finishing a game of Dota I tried to join another game and got
    and error message that read, "Another application is using a needed game port. Quit other applications and try again." I minimized and had nothing else running. Then I logged out of Bnet and tried signing back in. When I clicked the Bnet button I got a message that read, "Unable to validate game version. Please reconnect to Battle.net or apply the current patch manually."

    When I reported this to Blizzard Support they said I needed to go to Users/Shared/ And remove the blizzard folder. I did this and I still got the same message. I reinstalled the game and was able to get on to Bnet, but after 1 or 2 Custom games I got the, "Another application..." message and then sign out and get the "Unable to validate..." message. I have done this a view times now. I know it is not my CD Keys cause i can get onto battle.net fine on my girlfriends computer and stay on.(but it doesn't run as well).

    I have tried everything I can think of, and yes I did try to install the patch manually, but every time I reinstall the same thing happens, I get to play 1 or 2 games then I get those 2 error messages. Anyone know what I need to do to get this to work consistently? Thanks!

    P.S. No problems with single player
     
  2. Camtron thread starter macrumors newbie

    Joined:
    Jan 6, 2009
    #2
    I also forgot to say that I have no problems with Diablo 2 or Starcraft Bnet, and this problem didn't seem to happen until after I upgraded to Leopard.
     

Share This Page