Can't get phone to activate (5.0.1)

Discussion in 'Jailbreaks and iOS Hacks' started by MoodyM, Nov 14, 2011.

  1. MoodyM macrumors 6502a

    MoodyM

    Joined:
    Aug 14, 2008
    #1
    I have a 32GB 3G S, was locked to O2, so I jail broke it on 5.0, updated to baseband 6.15, and used Ultrasn0w to unlock it so I could put in an Orange SIM.

    This worked fine, but the guy who sold me the phone then told me O2 had notified him it had now ben officially unlocked, so I removed Ultrasn0w and again everything was still fine.

    Today I went to give the phone to my daughter, so I restored it to stock 5.0.1 firmware, then re-jailbroke, which is fine, except the phone won't activate. Everything else works, it just says "No Service" all the time and iTunes says there is no SIM inserted, and iOS 5's activation screen says "Cannot activate".

    I found a 5.0.1 custom ipsw online, called "iPhone 3GS-5.0.1_BB6.15.00_Activated", so I booted into pwned DFU mode and restored using that, but the problem persists - "No Service" and can't make or receive calls.

    I've tired different SIMs, same problem. Anything else I can try?
     
  2. MoodyM thread starter macrumors 6502a

    MoodyM

    Joined:
    Aug 14, 2008
    #2
    Fixed it, restored to stock 5.0.1 again, ran redsn0w and chose "Install Cydia", "Install iPad Baseband" and "Deactivate", and it worked.

    This guy's guide helped me out:

    http://www.youtube.com/watch?v=aNK_ZXqF6r0
     
  3. groove-agent, Nov 14, 2011
    Last edited: Nov 14, 2011

    groove-agent macrumors 6502a

    Joined:
    Jan 13, 2006
    #3
    Do you mean you restored it to 5.0? I didn't think you could unlock 5.0.1, only 5.0. If you try to select a 5.0.1 ispw with redsn0w, it says that it's not compatible.

    I checked out that video and followed it step by step but my iPhone still says "no service". It was the same as yours (same baseband etc), but mine was never at 5.0. I upgraded from an unlocked 4.2.1 to 5.0.1.

    I'm pretty sure I read somewhere that ultrasn0w cannot unlock 5.0.1. If I'm wrong, someone please correct me.
     
  4. MoodyM thread starter macrumors 6502a

    MoodyM

    Joined:
    Aug 14, 2008
    #4
    No, Restored to iOS 5.0.1, you can simply point redsn0w at the 5.0 ipsw file and it'll jailbreak/boot iOS 5.0.1 just fine.

    Also, I believe ultrasn0w works fine to unlock 5.0.1 too.
     
  5. groove-agent macrumors 6502a

    Joined:
    Jan 13, 2006
    #5
    Hmm ... i thought i read on the dev-team website that ultrasn0w doesn't work on 5.01. I did exactly what you did (and followed the video) and my phone still says "no service". So strange. It must work if yours is unlocked. I have no idea what I'm doing wrong, and have tried at least 3 times.
     
  6. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #6
    According to Dev team, ultransn0w has been updated so it compatible with OS5. They did not mention anything about 5.0.1, so I am not sure whether it will work or not. See the link to dev team for this info.

    http://blog.iphone-dev.org/
     

Share This Page