Can't get rid of the IOS9 Software update badge

Discussion in 'iOS 9' started by TB07-NJ, Aug 1, 2015.

  1. TB07-NJ macrumors 68020

    Joined:
    Jul 7, 2008
    Location:
    FORMERLY NJ now FL
    #1
    Not sure if this belongs in the 8 section or here but ......

    I had (not have) an iPhone 6 running IOS 9 "public beta." I replaced it with a 6 PLUS which Ifirst setup as new then reinstalled 1 app at a time from appstore all previous apps and didn't do a restore (couldn't even if I wanted to from 9->8) and went back to 8.4.

    For some reason I keep getting the notification and badge that IOS 9 Public Beta 2 has been downloaded and is ready to install. The phone doesn't even have the beta profile loaded. Is there any way to get rid of the download (if it is actually there) and to remove the notification?

    Would a reload of the OS then a restore from current 8.4 backup help?
     
  2. batting1000 macrumors 604

    Joined:
    Sep 4, 2011
    Location:
    Florida
    #2
    Have you tried a simple reboot or Settings > General > Reset > Reset All Settings?
     
  3. mman454 macrumors newbie

    Joined:
    Jul 12, 2015
    #3
    You still have the profile for the iOS 9 beta installed, which also tells me you restored from a backup that was made after you put the beta profile on your phone.

    To get rid of the profile: settings > general> profiles
    Select the one for the public beta and delete it, now reboot.
     
  4. TB07-NJ thread starter macrumors 68020

    Joined:
    Jul 7, 2008
    Location:
    FORMERLY NJ now FL
    #4

    Well, I would have thought that "restoring as new" through iTunes would have done it. No? I've probably rebooted about 15 times since restoring.
     
  5. batting1000 macrumors 604

    Joined:
    Sep 4, 2011
    Location:
    Florida
    #5
    Yeah it should, but it's not "restoring as new" unless you don't restore a backup. Restoring your backup could bring the issue with it.

    Try doing Settings > General > Reset > Reset All Settings

    The backup may have put the profile onto your new device, so try removing it from Settings > General > Profiles
     
  6. TB07-NJ thread starter macrumors 68020

    Joined:
    Jul 7, 2008
    Location:
    FORMERLY NJ now FL
    #6
    This happened AFTER I "restored as new" using a downloaded 8.4 IPSW through recovery mode and reloaded every app from iTunes. As my OP stated "The phone doesn't even have the beta profile loaded." I checked again to be sure and there isn't even a Profile menu option because it was overwritten with "restore as new." After restoring back to 8.4 there was nothing available to restore from 9 even if I had wanted to. All restore options were empty. My only choice was to start from scratch from iTunes.
     
  7. TB07-NJ thread starter macrumors 68020

    Joined:
    Jul 7, 2008
    Location:
    FORMERLY NJ now FL
    #7
    No profiles option on my phone any more and I did not restore from a backup I downloaded everything from iTunes. I will try reset all settings and see what happens.
     
  8. TB07-NJ thread starter macrumors 68020

    Joined:
    Jul 7, 2008
    Location:
    FORMERLY NJ now FL
    #8
    RESET ALL SETTINGS didn't help. BETA DOWNLOAD flag Still there.
     
  9. batting1000 macrumors 604

    Joined:
    Sep 4, 2011
    Location:
    Florida
    #9
    Log in to beta.apple.com and unenroll your device.

    https://beta.apple.com/sp/betaprogram/unenroll

    Leave the program at the bottom of the page. Then do a reboot
     
  10. TB07-NJ thread starter macrumors 68020

    Joined:
    Jul 7, 2008
    Location:
    FORMERLY NJ now FL
    #10

    The instructions to "unenroll" is to do exactly what I did. Restore in recovery mode with a 8 IPSW.
     
  11. batting1000 macrumors 604

    Joined:
    Sep 4, 2011
    Location:
    Florida
    #11
    go to the bottom and click the "Leave the program" link...
     
  12. TB07-NJ thread starter macrumors 68020

    Joined:
    Jul 7, 2008
    Location:
    FORMERLY NJ now FL
    #12
    All "leave program link" does (per the website) is:

    If you want to remove your account from the Apple Beta Software Program, click the Leave Program link below. If you leave, you will stop receiving emails and will no longer be able to submit feedback with Feedback Assistant.

    Doesn't seem to have anything to do with my problem. There is no feedback assistant on my phone and I don't care about emails. :) In any case, I am doing a "restore as new" again. If that doesn't fix it I'll just ignore it!
     
  13. batting1000 macrumors 604

    Joined:
    Sep 4, 2011
    Location:
    Florida
    #13
    So you're unwilling to try it to maybe see if it works considering you can't seem to resolve your issue? You can always re-enroll in the future if you wanted to. Enrolling is what gets you the updates. Perhaps removing your account from the server stops the updates.
     
  14. TB07-NJ thread starter macrumors 68020

    Joined:
    Jul 7, 2008
    Location:
    FORMERLY NJ now FL
    #14
    From Googling enrolling only allows you access to download the profile and puts you on the mail list. In any case, just for the heck of it, BEFORE unenrolling I am trying a restore and see if that clears it. If that dowe




    OK, I unenrolled.
    Nothing changed.
    I rebooted.
    Nothing Changed
    Then I did yet another "restore as new" and now it no longer says I should install the update and it says my software (8.4) is up to date. That's the good news.
    The bad news is the &*^&^&&* BADGE is still there! Rebooted 3 more times. Still there. I'll just live with it! Maybe when 8.4.1 comes out it will overwrite the &*^&^&^&* badge! I don't need no stinkin' badge! :D
    :mad::mad::mad::mad:
     
  15. batting1000 macrumors 604

    Joined:
    Sep 4, 2011
    Location:
    Florida
    #15
    Not sure what the issue would be...never seen anyone on here with that issue. Guess you'll just have to wait till 8.4.1 or 9.0. :)
     
  16. TB07-NJ thread starter macrumors 68020

    Joined:
    Jul 7, 2008
    Location:
    FORMERLY NJ now FL
    #16
    Yup .... that's about it. :(
     
  17. Shirasaki macrumors 604

    Shirasaki

    Joined:
    May 16, 2015
    #17
    So have you ever tried seeing settings app badge before starting recovering your device from the beginning? Oh, I forget that this option is not possible.
     
  18. GTDaveMac macrumors regular

    Joined:
    Jul 31, 2008
    #18
    I am not saying there isn't a way to get rid of the badge, but this exact same thing happened to me with the ios8 beta and I had to wait until ios8 was released until it went away.
     

Share This Page