Can't get SSD to work in iMac

Discussion in 'iMac' started by mrmicp, Aug 5, 2011.

  1. mrmicp macrumors member

    Joined:
    Nov 5, 2009
    #1
    Hi All,

    I have a late 2009 i7 iMac and recently upgraded the main HDD to a 2TB disk and while I was doing it I decided at a later date I would come back and replace the optical drive with a SSD......well here I am..

    So I got a caddy and replaced the optical drive with a Kingston 128Gb V+100, booted from a firewire drive with my lion install files on and proceeded to install Lion. I went into disk utility and partitioned the drive (extended journal and GUID) then set off the install. It does the first 3 minute part ok then when it reboots to continue the install I get the apple symbol then I get the no entry style sign flashing.

    So I booted into my main 2TB HDD went into disk utility and repartitioned the SSD then I ran verify disk which came back with errors (invalid B-tree node size) and told me I need to repair the disk, so then I tried to repair the disk which again came back with the error that disk utility couldn't repair the disk.

    So i'm at loss, my next step would be to install it while connected to a USB caddy then if that works drop it back in the mac.....BUT i'm beginning to think that either the drive is faulty or for some reason the mac doesn't like the SSD.

    Anybody experienced anything similar?
     
  2. Dresevski macrumors 6502

    Joined:
    May 6, 2011
    Location:
    Minnesnowda
    #2
    Sounds like an odd problem. I formatted my SSD via USB adapter then threw it into my computer. I have the newer model so I didn't have to put it in place of the optical drive but I had no issues booting from the SSD immediately. Make sure to check that everything is fine while it's outside the Mac, meaning hold down the option key and boot from it while it's plugged in through firewire/usb.

    If it's the drive then you have some more issues to deal with.

    Don't you have to install SL first on the SSD then upgrade to Lion?
     
  3. mrmicp thread starter macrumors member

    Joined:
    Nov 5, 2009
    #3
    I downloaded lion from the app store but before I installed it I took a copy of the installesd.dmg file then just restored it to my FireWire drive. You can then boot off it and do a clean install.
     

Share This Page