Can't get wireless to work in Leopard

Discussion in 'macOS' started by Trippy Jr, Oct 26, 2007.

  1. Trippy Jr macrumors member

    Aug 10, 2006
    This is very annoying.

    Just flattened my Mac Pro HD for a new Leopard install. Went ahead and did it, all went fine... and now it won't connect to my wireless network using WEP, WPA, or anything apart from disabled.

    It just goes to "connection timed out" or "connection failed", leaving me with the only option of leaving my connection unsecured. This is driving me mad! There's surely no reason why this would become such a big issue.

    And yes, I have tried rebooting everything, etc.
  2. somberlaine macrumors member

    Jul 1, 2007
    Fairfax, VA
    I am having the same issue. The only way for me to connect is removing WEP. Other that the error messages you have been getting, I also get a message saying INCOMPATIBLE SECURITY. I am using an old Belkin wireless b to connect (I know it is too old but it has been working fine)
  3. I WAS the one macrumors 6502a

    I WAS the one

    May 16, 2006
    same here. My others macs with Tiger installed works fine it just the Leopard one that can't connect to a WEP secure router. it keep saying INCOMPATIBLE SECURITY.. anyone that can help us here?
  4. DaneKurb macrumors newbie

    Oct 29, 2007
    i am having the same problem. i have a wireless access point that works fine with every other computer in the house except the Leopard MacBookPro15. You'd think that it wouldn't give me any problems, but it keeps saying INCOMPATIBLE SECURITY
  5. Cybix macrumors 6502a


    Feb 10, 2006
    Western Australia
    Did any of you do a software update after installing leopard, or are these issues directly from a basic leopard install without doing further updates?

    I'm experiencing NO WIRELESS at all on my G5 iMac after doing the latest software updates :)
  6. somberlaine macrumors member

    Jul 1, 2007
    Fairfax, VA
    it works fine with my iPhone

    And before now with tiger. What kind of WEP encryption are you guys using? I am using a 128 hex. Did u guys call apple support? I am planning on calling them tomorrow. I think this incompatiblity issueis closely linked to the keychain issue which apple fixed thru software update. It is too little too late since. My keychain is a mess already.
  7. DaneKurb macrumors newbie

    Oct 29, 2007
    i just did the update (keychain and one other) on a freshly installed leopard macbookpro, and i am still getting INCOMPATIBLE SECURITY as a result.

    this purchase was a large jump into the mac world from a pc and i'm not overly impressed with it yet. it's given me nothing but trouble from day one, and this internet business is pushing me towards selling the damn thing while the value is high
  8. Justinerator macrumors 6502


    Jun 26, 2007
    Redondo Beach, CA
    new question...

    I was wondering how the 802.11n upgrades for the 2.16/2.33 work once you have installed leopard. Do you just install it like you do in tiger? Or is there another way? Thanks in advance!

  9. Lava Lamp Freak macrumors 65816

    Jun 1, 2006
    After installing the keychain update I could no longer connect to my Airport. I was getting the Connection Failed and Connection Timeout errors. I turned off WPA security and now I can connect again. My connection did drop once, though, so that is another issue. With Tiger I never lost a connection and could use WPA without issue.
  10. fredstahl macrumors newbie

    Jan 16, 2008
    Workaround for Leopard "incompatible security"

    uite by accident, i discovered a practical albeit cumbersome way to get back on your wireless network.

    1. When you awaken Leopard you get the "None of your preferred networks are available" message.

    Cancel it.

    2. Ask Safari to open any page. It will, of course, hang with the message "You are not connected to the Internet."

    Click on the "Network Diagnostics..." button in the message box.

    3. You should get a dialog box titled "Network Diagnostics". The list of "locations" should have the name of your usual network setup highlighted in gray. All the network status signals down the left side will be red.

    Click on the "Continue" button in the dialog box.

    4. You should see a fresh Network Diagnostics box subtitled "Choose network port configuration"

    Click on the AirPort radio button.
    Then click on continue.

    5. The Network Diagnostics box should be refreshed. You should now see "Select AirPort network" as a subtitle, and one or more wireless network names listed.

    Click on your wireless network name (the one your AirPort knows).
    Click the Continue button.

    6. Type your password in the Password box in the next refresh. (No need for a $. Just your password.) (Don't bother checking the Remember password... box. It seems non-functional.)

    7. Click the Continue button.

    8. The Network Fairy awakens, makes all the status signals on the left green, turns on your wireless signal strength icon in the top bar, loads your Safari page, and leaves you with the message: "Your Internet connection appears to be working correctly."

    9. Beats me why the "other" WEP password entry process consistently fails.

  11. farjang macrumors newbie

    Feb 26, 2008
    Sometimes you need to update the Firmware of the Access Point


    I have the same problem, once I update my Mac, I cannot access my Westell Model: A90-327W15 it was working before until I update my Mac. I tried everything from no security, MAC Address filter, WEP, and WPA didn't work. Then I figure it might be the firmware, I am a Verizon customer and I am using their: Westell Model: A90-327W15

    So I download the new Firmware (Windows XP & Ethernet Cable required) from here: ( you wont find this on Westell, they said to call Verizon)

    Once I did the FIRMWARE update, then restart and I get connection right away. So the problem is not MAC (well, kinda) but the Access Point.

    I didn't have the solution for other Accesspoint but I am sure the same thing will work.

    Good luck,

  12. elbee macrumors newbie

    Nov 2, 2009
    Can't get wireless to work in Leopard


    It looks like a lot of us are having similar problems.
    I followed Fredstahl's directions but got stuck on:
    "Click on your wireless network name (the one your AirPort knows)."

    My wireless network name was not among the wireless names listed.
    The times I when I am able to connect, my wireless name IS listed.

    When I had the option to connect manually by entering my Network name, I get "Connection timeout". This is about the third time this has happened to me.

    A few minutes ago, I was connected... all morning in fact. And the PC in my house is still able to connect, so my wireless network is working fine.

    Just before I found myself disconnected, I had been working on reserve power, so I attached the power cord and closed my laptop (a new MacBook Pro, Mac OS 10.5.8, Snow Leopard not yet installed). When I opened it a few minutes after closing it, I was no longer connected and got the message: None of your preferred networks are available.

    The last two times this happened, I got nowhere, so I left the computer for a while. When I returned, all was working just fine. Fortunately so far, nothing I was doing was so urgent I couldn't wait.

    There MUST be a fix for this. And it must be a MAC problem. My internal wireless network is not locked. It just requires that all devices using it register their M.A.C. numbers, so it's not a security problem, either. This is just baffling.
  13. jrraines macrumors newbie

    Dec 2, 2009
    be patient

    I looked this thread up because I was having what seemed like the exact problem described here. Everything had worked perfectly, then I traveled out of town and was using the unsecured wireless at my parents house for a few days. When I returned home it suddenly had trouble finding my home networks.

    No software upgrade had occurred to blame. What I've realized is that once I got upset with the process, I would click on the wireless icon on the right side of the menubar and watch or try to assist the MBP finding the network. DON'T DO THAT. My MBP is back to reliably finding the secured network at home without any real change on my part other than my realization that I need to give it a moment or two after I awake it from sleep to negotiate with the network. That seems to happen MUCH more reliably if I don't open the menu item. I'm not saying there's not a software flaw in what happens when you open that menu item or that the menu doesn't need to be used when you do travel between networks, but when you're home patience seems to be the most effective strategy. YMMV, of course.
  14. crabbyphoto macrumors newbie

    Mar 30, 2004
    Wireless - Verizon & Mac Mini problems ????

    I realize this is an old thread.
    But was this problem ever resolved?

    I purchased a version 2,1 Mac mini used and have not been able to connect to my existing Verizon Westell DSL wireless.

    I have had a 27" iMac on this system for almost three years without a problem.

    My Mac Mini would connect but like other folk I have the same problem with it timing out.

    I contacted Verizon and the service rep even took control of my Mini and was unable to make a proper connection. She then had a new DSL Westell sent for replacement. I made the replacement and established a good connection with my iMac again but still no service for my Mini. I went through the process again with a service rep and he told me I must have a bad Mac. I am thinking that is NOT the problem and it must be something simple.
    #1 does anyone know of a fix for this problem?
    #2 could I bypass the internal wireless receiver in the MacMini and just add this airlink to the mini via USB and solve my issues?

    This is not only confusing but annoying.

    Any help would be appreciated. I need to do something by tomorrow.

  15. crabbyphoto macrumors newbie

    Mar 30, 2004
    Connection help....

    Giving this a bump - not sure if it posted


Share This Page

14 October 26, 2007