Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Galacticos

macrumors 6502a
Original poster
Apr 5, 2016
692
379
dont seem to be able to turn caller Id off in settings. The switch goes off, but I called out and the recipient knew it was me.

Anyone else had this?
 

chscag

macrumors 601
Feb 17, 2008
4,622
1,946
Fort Worth, Texas
I'm not certain but I believe the caller ID setting depends on your carrier. Even if you set it off on your phone, your carrier may not honor that which is why the call recipient knew it was you.
 

NoBoMac

Moderator
Staff member
Jul 1, 2014
5,941
4,548
Works for me.

As chscag said, might be on carrier end. For example, I believe Verizon is supposed to be able to take *67 numbers, but also has it as a setting under one's account settings on their website.

Also, government agencies, 800 numbers, business numbers(?) are getting the "real" caller id information not what we consider caller id. And believe there are services that will route a call through said service to provide receiver with the "real" caller id.

The caller id switch is for native app only, so things like the Google Voice app will not use the iOS option.
 

Galacticos

macrumors 6502a
Original poster
Apr 5, 2016
692
379
It’s always worked on my carrier.

And when I turn it off and reboot my phone, my number is hidden. So I think it’s a bug
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.