Can't import photos anymore -- unreadable file error

Discussion in 'iPhone Tips, Help and Troubleshooting' started by tomtom123, Jul 28, 2007.

Thread Status:
Not open for further replies.
  1. tomtom123 macrumors newbie

    Jul 28, 2007
    I'm not sure what happened, but I can no longer import photos from my iphone to my Mac. iPhoto and Lightroom both say there are 26 photos to import on my iPhone. However, when I try to import, it says the files are not valid and fails (screenshot attached). The odd thing is that I actually have 48 pictures on my iPhone under Camera Roll.

    I have no idea how I can fix this problem. I really want to save the pictures under the iPhone camera roll. Any ideas or help? Thanks!

    Attached Files:

  2. 61132 Guest

    Oct 31, 2005
    I have the same exact problem. Don't know how to fix it, but you can get all your photos by connecting the iphone to a windows computer (don't sync it) and the "camera" will show up in my computer, you can then pull all the photos off of it. I have also been having the problem where iPhoto does not even see that the iphone has pictures on it.

    You would think apple would have gotten it the other way arount (works perfectly under os x and small problems under windows.)
  3. tomtom123 thread starter macrumors newbie

    Jul 28, 2007
    How ironic! You are right...connecting to a windows PC allowed me to download the photos. However, I still can't fix the problem with my iPhone/Mac. I tried a restore and it still tells me there are 26 unreadable photo files. Any help?
  4. 61132 Guest

    Oct 31, 2005
    Try this, it worked for me:

    Start iTunes and iPhoto
    Plug in iPhone
    Let iTunes finish syncing
    go to iPhoto
    Press home button on iPhone, slide the slider to unlock the phone
    Go back to iPhoto, now try to import the photos

    It seems that iPhoto needs the phone on and unlocked to import photos. You would think Apple would have gotten it to work better, well heres hoping for an update soon!
  5. tomtom123 thread starter macrumors newbie

    Jul 28, 2007
    That doesn't seem to matter on mine. The problem is, there are no photos on my iPhone, but iPhoto seems to think there are still 26 photos. I have no idea how to get rid of those 26 "ghost" photos...
  6. kevinwiz macrumors regular

    Feb 1, 2007
    i'm having a similar problem and it also thinks there are 26 photos. oddly enough, i also went to a windows pc and it saw the 42 pictures just fine:eek:

    in the first screen shot, notice it shows an existing photo, but the import box is blank.
    in the second screen shot, notice it says from 7/2 to 7/20. well today is 7/30

    i will post this on apple forums

    Attached Files:

  7. tomtom123 thread starter macrumors newbie

    Jul 28, 2007
    After an hour and a half on the line with tech support, its been resolved. Here's what they had me do:

    Close iPhoto
    Disk Utility -> Verify Mac HD
    Disk Utility -> Repair Mac HD (2x)
    Delete /library/preferences/
    Delete /library/preferences/
    Delete /library/preferences/
    Delete all photos on phone
    Take a few photos with camera
    Start iPhoto
    Import --- it worked!

    Let's hope this doesn't happen to others.
  8. rockrep macrumors newbie

    Sep 9, 2008
    I had a similar issue, however, only a reboot was necessary to resolve it. Disk Utility Verify showed no issues, and I did not have any of the files listed in the previous thread.
  9. trevorbsmith macrumors member

    Dec 17, 2007
    I was having the same issue. I tried advice at Apple's and other web sites but they all failed to fix for me. Among the things I tried: deleting various plist files in /Library/Preferences (should have tried the ones in ~/Library/Preferences too but forgot to); reset the settings on my iPhone; reboot iPhone; hard reboot iPhone. Nothing worked.

    As an aside, iPhoto and iTunes had both STOPPED auto-starting when I plugged in my iPhone. Both "saw" the iPhone when I manually opened them or if they were already open when I plugged it in. No settings seemed to explain this behaviour.

    Then I tried this advice (reboot my Mac). That FIXED the problem. Astounding. Makes me feel like I'm using a Windows machine if I have to reboot it. What ridiculous nonsense.
  10. mayall macrumors newbie

    Jul 26, 2009
    Try using different USB

    I think my problem was different but hope others might find this useful.

    Everything worked perfectly with the iPhone, camera, iTunes, and iPhoto. But iPhoto always showed 0 photos. Image Capture also showed 0. Only PhoneView showed photos and let me export them.

    Tried every fix I could think of even deleting the dDCIM folder using PhoneView.

    Finally, I move the USB cable to a different port. Fixed. Moving it back to the old port and it was broken again. Very odd fix for what seemed like a software problem.

    Will Mayall
  11. Galarina macrumors member


    Jun 27, 2009
    My iPhone app PhotoToMac allows you to transfer camera roll photos wireless to a Mac.
  12. bigcat66 macrumors newbie

    Apr 20, 2010
    One fix

    Take another picture with the iPhone, so you are adding another photo to camera roll. That worked in my case. Also, you made need to unsync photos in iTunes under the photos tab.
  13. ModernGeek macrumors newbie


    Apr 4, 2006
    Murray, KY
    Solved with reboot.

    It must have something todo with the caches and the way it handles previewing the pictures before downloading them. I believe that this was caused by my impatience in unplugging the phone or force quitting iPhoto while it was loading the image previews. Would explain because I've had this issue before, and would try the import again days or weeks later with success. Must have been the reboot. Just had the problem again and the simple reboot solved this for me. Good thing I didn't have to email all the photos to myself! Might see about investing in the App mentioned above.
  14. djrobx macrumors member

    Dec 17, 2007
    I have this problem as well, been going on for well over a year.

    I just use Windows to get my pictures to get around it. Windows has never had a single problem pulling a picture or video out of the phone.
Thread Status:
Not open for further replies.

Share This Page