Can't import photos from Kodak camera

Discussion in 'Mac Basics and Help' started by yettimillan, Jul 6, 2010.

  1. yettimillan macrumors regular

    May 28, 2009
    Hi. I have a Kodak easyshare V1253 Camera.
    It won't let me import photos and videos from the camera via iPhoto. Just says error downloading image.

    If I go into bootcamp it imports fine on windows.

    How can i fix this? I would much like to have a way to take pictures directly from the camera rather than through iPhoto like in the finder. Is this possible as when i plug in my camera nothing comes up.

  2. spinnerlys Guest


    Sep 7, 2008
    forlod bygningen
    As far as I have experienced, the Kodak Easyshare cameras don't show up in Finder for you to manually drag the contents off it (in Mac OS X).

    You could get a cheap SD-card reader (5 to 9€) and get that done via that device.

    Have you installed the drivers via the accompanying installation CD? Have you tried Image Capture?
  3. yettimillan thread starter macrumors regular

    May 28, 2009
    Ahh thanks image capture works. Never even used it before though.

    Ohh actually it comes up just still wont import it? Strange.
  4. spinnerlys Guest


    Sep 7, 2008
    forlod bygningen
    So you can see a mountable volume in Finder's Sidebar? That's new, as my camera and some other Kodaks I came upon didn't do that. Maybe Kodak finally got their heads out of whatever collective arse they had it in.
    Someday Canon will too I hope.

    How do you try to import your photos into iPhoto anyway and which version of iPhoto do you have?
  5. forcefieldkid macrumors 6502

    Jan 20, 2010
    I use a Kodak Easyshare camera and while someone might be able to elaborate, it seems to go like this for me...

    Open iPhoto. Connect camera and turn it on. iPhoto auto detects the camera and asks if I'd like to import.

    You should also have some Kodak software that came with your camera, install that and see if it works that way if you're still having problems.

    Very basic but I hope it helps
  6. brianwebb macrumors newbie

    Apr 3, 2008
    Another problem

    I had a similar issue. My problem was that my camera up until about 3 weeks ago worked fine, now it says the picture files are unreadable. Same camera, same card, but it won't show any pictures from the last few weeks.
  7. aross99 macrumors 68000


    Dec 17, 2006
    East Lansing, MI
    There is an issue with iPhoto and the Kodak cameras if you have a video on your camera. This will stop iPhoto from loading the photos. Only work around I have found was to use Image Capture, or delete the video(s).

    This has been a problem in the past, and it has been fixed before. It seems to be back now, and hopefully will be fixed soon...

Share This Page