Can't insert CD/DVD in iMac DVD drive

eldudorinio

macrumors member
Jan 16, 2010
54
1
0
Hello,

My gf has a new 21.5 inch iMac at 3.06GHz (iMac11,2 , July 2010) with 4GB RAM and after about a month of working properly, all of sudden we cannot insert disks in the DVD drive.

It is very strange because the drive does not pull the disks in like it would normally. It feels like when you push the disk in, it hits something inside when the disk is half way in. That something is NOT another disk. It is empty.

What I have done so far is:
1) Tried the Eject button on the keyboard with no success
2) Tried Force Eject on startup by holding down the mouse button with no success
3) Checked Disk Utility drive status, which said there is no disk inside
4) Did the Apple Hardware Test at startup, which did not find anything

I did not reset PRAM or SMC as I did not think it has to do with the DVD drive.

If you need any more info please let me know.

Does this mean that the DVD drive is faulty? Any ideas?

Thanks,

Yiannis
 

Hellhammer

Moderator emeritus
Dec 10, 2008
22,076
580
0
Finland
Let Apple have a look. SuperDrives are known to be problematic so unless there is another disc or something in it, it's defective.
 

eldudorinio

macrumors member
Jan 16, 2010
54
1
0
Thank you for the quick response.

That's what I was thinking, but wanted to see if there was anything I could do.

Cheers.
 

Mr. Spike

macrumors newbie
Nov 22, 2011
1
1
0
Can't insert CD/DVD in iMac DVD drive

I know this is an old post....but this just happened to yesterday (11/21/11). I have a 27" iMac with the same slot drive. The good news is I found a solution to my problem so hopefully others will find this info useful as well.

First, here's what happened to me. I was making a copy of a DVD movie. I put a DVD in the drive. All good so far. The software completed copying the movie and ejected the DVD and asked that I insert a blank DVD into the drive to continue with the copy. So, I removed the DVD movie and I attempted to insert a blank DVD. Heres where I encountered the problem. I couldn't insert the blank DVD. It was exactly like "eldudorinio" posted. Upon inserting the DVD halfway, it felt as if something was blocking the disc from going in. The normal "suck the disc in" was not happening.

So, after trying all the information I found reading forums on this problem (ie., holding eject during reboot, holding mouse key during restart, holding "C" during startup, etc.) nothing worked. I called Geeksquad, cause I have a 4 year warranty, and they wanted me to bring it in. Certainly they would be shipping if off and I'd be left without my computer for weeks. NO WAY.

So.....Here's what I did and problem solved:

Place the DVD/CD into the slot drive to the point where the resistance is felt. Next, take your open hand, and gently tap the outer edge of the disc inward towards the opening with your four fingers. Continue tapping the disc (like you are trying to tap the disc into the drive) and gradually increase the force of the tap until, bingo, the disc sucks into the drive!!!

I hope this helps anyone else having this problem. I joined this forum just so I could post this. Good luck!
 
  • Like
Reactions: BD-ONE

marksmac

macrumors newbie
Dec 31, 2011
1
0
0
This worked for me too!

Thanks Mr. Spike!!!

This worked for me too! Just a gentle tapping to slowly force the cd in worked. Just enough to force the mechanical tray to move the disc inward did the trick. I was then able to eject the disc and it continued to operate normally again. I was tickled I just had to register to say thanks.

Mark



I know this is an old post....but this just happened to yesterday (11/21/11). I have a 27" iMac with the same slot drive. The good news is I found a solution to my problem so hopefully others will find this info useful as well.

First, here's what happened to me. I was making a copy of a DVD movie. I put a DVD in the drive. All good so far. The software completed copying the movie and ejected the DVD and asked that I insert a blank DVD into the drive to continue with the copy. So, I removed the DVD movie and I attempted to insert a blank DVD. Heres where I encountered the problem. I couldn't insert the blank DVD. It was exactly like "eldudorinio" posted. Upon inserting the DVD halfway, it felt as if something was blocking the disc from going in. The normal "suck the disc in" was not happening.

So, after trying all the information I found reading forums on this problem (ie., holding eject during reboot, holding mouse key during restart, holding "C" during startup, etc.) nothing worked. I called Geeksquad, cause I have a 4 year warranty, and they wanted me to bring it in. Certainly they would be shipping if off and I'd be left without my computer for weeks. NO WAY.

So.....Here's what I did and problem solved:

Place the DVD/CD into the slot drive to the point where the resistance is felt. Next, take your open hand, and gently tap the outer edge of the disc inward towards the opening with your four fingers. Continue tapping the disc (like you are trying to tap the disc into the drive) and gradually increase the force of the tap until, bingo, the disc sucks into the drive!!!

I hope this helps anyone else having this problem. I joined this forum just so I could post this. Good luck!
 

flynz4

macrumors 68040
Aug 9, 2009
3,125
35
0
Portland, OR
Thanks Mr. Spike!!!

This worked for me too! Just a gentle tapping to slowly force the cd in worked. Just enough to force the mechanical tray to move the disc inward did the trick. I was then able to eject the disc and it continued to operate normally again. I was tickled I just had to register to say thanks.

Mark
I just received a call from a friend who had this exact same problem. I remember reading this thread, so I searched and told her about the procedure and it worked perfectly.

Thank you Mr Spike and Mark.

/Jim
 

Macman45

macrumors G5
Jul 29, 2011
13,196
133
0
Somewhere Back In The Long Ago
It's the way the mechanism is designed...It's cool when it works (mine has up to now on my iMac) but something there is clearly not completing it's "Cycle" Worth knowing if I run into the same issue, but with AC on all my Macs...I would probably have it replaced.
 

flynz4

macrumors 68040
Aug 9, 2009
3,125
35
0
Portland, OR
It's the way the mechanism is designed...It's cool when it works (mine has up to now on my iMac) but something there is clearly not completing it's "Cycle" Worth knowing if I run into the same issue, but with AC on all my Macs...I would probably have it replaced.
She has AC on all of her computers too. Her iMac is 1.5 years old... I'll have her keep track and if it fails again, she can bring it in.

/Jim
 

Arranyn

macrumors newbie
May 15, 2012
1
0
0
Genius!

You Sir, are a genius...

Had given up hope after trying all the 'usual' reboot and key combinations. Was just about to take the whole iMac apart and stumbled on this at the last minute.

Worked a treat!

Many thanks!
 

Marc7747

macrumors newbie
May 28, 2012
1
0
0
Colorado
iMac 24" Drive not pulling in disk

The drive would not pull in the disk. No noise, no stuck disk-the disk just sat in the drive with about 1/8" exposed. Tried restart, sleep, etc. which did not work.

What did work, at least for now, was opening the Disk Utility and clicking on the optical drive. Once I did that everything was OK and the drive mechanism is now functioning.
 

chasemac

macrumors 6502a
Jan 30, 2005
759
65
0
In a house.
Spent some time with this issue tonight. I have a 27" iMac mid 2010. After watching a dvd, I ejected it and then went to insert another. It seemed like the drive was blocked by something and I didn't want to force the disk inn so I did a search for the problem and came to this thread. The tap trick worked for me as suggested above, but then after watching the movie, it wouldn't eject all the way. After ejecting several times, I was able to catch it with my finger nail and hold till I used some tweezers to get the disk out. The drive is "out of wack" to use as a technical term. After further thought, in the past the drive seemed "a little stiff" when I would insert a disk and this may have been a silent progression of a future drive problem. I wonder what more I can do besides taking her in for a checkup and throwing some cash at the problem?
 

Juciluce

macrumors newbie
Jan 30, 2012
2
0
0
Place the DVD/CD into the slot drive to the point where the resistance is felt. Next, take your open hand, and gently tap the outer edge of the disc inward towards the opening with your four fingers. Continue tapping the disc (like you are trying to tap the disc into the drive) and gradually increase the force of the tap until, bingo, the disc sucks into the drive!!!

I hope this helps anyone else having this problem. I joined this forum just so I could post this. Good luck!
Worked a treat!
Thank you for joining just to share this- what a star!
Juciluce xx
 

Jazzman25

macrumors member
Jan 15, 2007
43
0
0
imac 27 - piece of carton stuck inside drive

I am taking advantage of this thread as it is the most recent one and the closest I found to my topic.
A few weeks ago I dropped by mistake an SD card into the optical drive slot. As this is an "accident" happening a lot it seems, I easily found a tutorial on how to recover the card with an L shaped carton that you stick into the slot drive. Unfortunately in this process a small part of the carton boke and was left inside the slot. I am still able to have the drive read some CD/DVDs but with difficulty and sometimes this is not working. I am not able to reach this little piece and taking the machine a part just for that is too risky. What can I do? I do have an Apple Care in place, but I don't know if Apple will agree to take the iMac for fixing, and I cannot afford to have the machine away for weeks. Any advice?
 

stafro

macrumors newbie
Jul 19, 2012
1
0
0
I can't agree more....

...thanks for registering to post your solution on difficulties inserting CD/DVDs. Your "tapping" advice was just what the doctor ordered -- although, perhaps, not something I would have tried right away if it hadn't been for the almost unanimous thumbs up from other users.

Again...thanks!
 

AnneWithAnE

macrumors newbie
Aug 10, 2012
1
0
0
Success achieved after waiting overnight

Thanks to all for advice and comments! Last night, I tried all the steps mentioned but no success. This morning, after computer had been asleep overnight, I noticed that the CD (still sitting in the drive slot) was a little further in than before. I gave it a push and it went all the way in and started up. Thanks, again.
 

xxMACxx

macrumors regular
Jul 26, 2008
137
10
0
Worked for me

Thanks for posting this... This solution worked great for me too!

Michael
 

motrek

macrumors 68020
Sep 14, 2012
2,317
118
0
Just FYI, if you have a broken optical drive you can get an external USB drive for $25 these days. No need to open the computer.
 

kjones111

macrumors newbie
Nov 8, 2011
3
0
0
I just tried it and it didnt quite work. Now there is a disk inside there that most likely will not come out.

I tapped it and it seem to get past the resistance but still didnt get taken in like normal. I kept tapping it hoping to feel something and it went right in and now I can't get it out.

Anybody know how I am going to get it out of there?
 

RBinNC

macrumors newbie
Nov 24, 2012
1
0
0
Just so everyone knows, "tapping" a disc into your drive is not a real solution. At some point you will scratch a disc beyond usefulness as well as damage the optical drive permanently.

I know this is frustrating and I am so mad about this, (and several other problems my 27" imac has had), that I will not purchase Apple products again unless their customer service improves drastically. In fact, I just bought two tablets and they were not ipads. There are a lot of other choices now-a-days that are just as good, or better, as Apple products, so use your power as a consumer and do not buy Apple products until they start treating the consumer with respect and own up to the design flaws in their products.
 

mushroomtip

macrumors 6502
Oct 27, 2012
354
0
0
I wouldnt be doing that . Apple would be getting a call . they want premium prices , I want premium products and Service .just for the record . Ive never had a problem with Apple Customer Service When ever I had to call. they were always professional and helpful . I even got help one time on the phone after the 90 days was up.
 

Tellyanna

macrumors newbie
Feb 18, 2013
1
0
0
Thank you So MUCH

I have had this problem for about a month Tried all the above mentioned and Finally stumbled on this post for which I am very great full. However the tapping did not work with my machine. I Had a noisy vibration with my drive as well as the blocked half way so I had to hold the disk while inserting then pull on it when it tried to suck it it a few times then it accepted the disk and all has been well. I then ejected the disk and tried to re insert and its working again Thanks for this post! I would have never attempted to do anything like this! I was afraid to damage the drive! :D
 

imacrazy

macrumors newbie
Mar 30, 2013
2
0
0
It worked, I was so surprised!

This is an old thread and post (a couple years old), but I've been looking for the last 5 months (it's now 2013) for something that would work . . . I have the identical iMac with the same problem; my dvd would not load, it hits something when you try to insert it. I tried everything (reboot holding esc, eject using terminal commands, etc), but the simply tap it in until it inserts, worked! Amazing.

I figured it wasn't working, so what did I have to lose, so I put the disc in as far as it could go (it only would insert about half way), then I pushed the disc towards the screen while I gently tapped the side of the disc . . . and the computer sucked it in, and it worked!

I ejected the disc, and now I can insert and play any disc I want. Who would have thought, a gentle tap on the side of the disc and all my woes disappeared.

Thank you for your post and suggestion!

I know this is an old post....but this just happened to yesterday (11/21/11). I have a 27" iMac with the same slot drive. The good news is I found a solution to my problem so hopefully others will find this info useful as well.

First, here's what happened to me. I was making a copy of a DVD movie. I put a DVD in the drive. All good so far. The software completed copying the movie and ejected the DVD and asked that I insert a blank DVD into the drive to continue with the copy. So, I removed the DVD movie and I attempted to insert a blank DVD. Heres where I encountered the problem. I couldn't insert the blank DVD. It was exactly like "eldudorinio" posted. Upon inserting the DVD halfway, it felt as if something was blocking the disc from going in. The normal "suck the disc in" was not happening.

So, after trying all the information I found reading forums on this problem (ie., holding eject during reboot, holding mouse key during restart, holding "C" during startup, etc.) nothing worked. I called Geeksquad, cause I have a 4 year warranty, and they wanted me to bring it in. Certainly they would be shipping if off and I'd be left without my computer for weeks. NO WAY.

So.....Here's what I did and problem solved:

Place the DVD/CD into the slot drive to the point where the resistance is felt. Next, take your open hand, and gently tap the outer edge of the disc inward towards the opening with your four fingers. Continue tapping the disc (like you are trying to tap the disc into the drive) and gradually increase the force of the tap until, bingo, the disc sucks into the drive!!!

I hope this helps anyone else having this problem. I joined this forum just so I could post this. Good luck!