Can't insert cd/dvd into my powerbook

Discussion in 'PowerPC Macs' started by namethisfile, Jul 1, 2009.

  1. namethisfile macrumors 6502a


    Jan 17, 2008
    I have a 12" powerbook that I've been using for years. Well, today, the combo drive suddenly doesn't want to accept dvd's anymore. It worked as recently as last night. I've researched this topic all day today to find a solution and none of them work. I have run out of ideas. Before calling it quits, I thought I'd ask for advice/solution here.

    One odd thing though that might be related to this problem is that I tried ejecting a dvd movie, maybe, yesterday and it would eject only half way as if something was stuck before the drive would take it back in. So, I helped the cd out by manuall pulling it when I ejected it the 2nd time. There was some resistance and I feared I might have done something to it but by the looks of it, everything went back to normal. I was able to insert the same dvd and play it and then ejecting it was also normal after that. And then, this happened this morning. It's as if something in the drive itself is preventing the dvd to be inserted all the way in. The dvd only goes up to as far as the tip of the inner circle before I can't push it any longer. There is no cd, dvd, or foreign matter in there that I know of.

    Does this sound familiar to y'all? Any clues as to how to fix it? I've gone as far as sticking a paper clip in their out of desparation but no clue of what to do. i need the drive to work to watch movies on.

Share This Page