Can't insert CD into Mac mini??????

Discussion in 'Mac Basics and Help' started by lindao9, Dec 2, 2011.

  1. lindao9 macrumors newbie

    Joined:
    Dec 2, 2011
    #1
    I just installed Parallels, ejected that disc, and want to now install Windows, but I can only get the CD in about halfway. It feels blocked and I don't want to break the CD or the drive by forcing it in. It really feels like I will break the disc before whatever is blocking it will give.

    I tried re-starting but it's still doing it.

    What can I do?

    My husband is the computer person in our household but he's working a side job tonight, so if anyone is around and can help, that would be great!
     
  2. jabbott macrumors 6502

    Joined:
    Nov 23, 2009
    #2
    Hmm, my first thought was "is there still a CD in there?!" but from your description that isn't the case... I also saw that you rebooted... did you also try powering it off all the way and then back on? One other trick which used to work with PowerBook G4 slot loading CD drives is to hold the eject button down for a few seconds right after turning on the computer. That would force eject CDs that were stuck in the drive. In your case it might reset the positions of the drive components enough to allow a CD to be inserted again.
     
  3. chilp macrumors newbie

    Joined:
    Dec 4, 2011
    #3

    Did you get a solution? This sounds exactly like what has just happened on my Mac Mini a few days ago.

    It gets in about half way before something blocks it and it doesn't take the disc. I've tried restarting, powering down completely and tried a number of different CDs/DVDs. Nothing seems to work. I'm thinking I'm going to need to take it to my local Apple store.
     
  4. peterskim macrumors newbie

    Joined:
    Jan 9, 2004
    #4
    This just started happening to me too... about a week ago. I rarely use my optical drive, but still. Maybe the new Mac Minis are jealous that their older siblings have optical drives and they don't.
     

Share This Page