Can't insert DVD in MacBook Pro

Discussion in 'MacBook Pro' started by sillygoose1988, Nov 11, 2010.

  1. sillygoose1988 macrumors member

    Joined:
    May 4, 2010
    #1
    Hello!
    i have a big problem with my macbook...i can't insert a Dvd in!
    there's no DVD inside...i don't know what the problem is!
     
  2. lavrishevo macrumors 68000

    lavrishevo

    Joined:
    Jan 9, 2007
    Location:
    NJ
    #2
    Sounds like your DVD/CD drive bit the dust. Mine went out after about 3.5 years. DVD drives and batteries seem to be the most common parts to go bad.
     
  3. sillygoose1988 thread starter macrumors member

    Joined:
    May 4, 2010
    #3
    it is strange though...it's like something is blocking the right side...i've had my macbook for just a year or so! that shouldn't happen so quickly!
     
  4. sillygoose1988 thread starter macrumors member

    Joined:
    May 4, 2010
    #4
    nobody to help me?
    looks like there's some kind of lock or something...
     
  5. Resist macrumors 68030

    Joined:
    Jan 15, 2008
    #5
    I would try the procedure used to remove a stuck disk and see it that unlocks it.
     
  6. lickitysplit macrumors regular

    Joined:
    Sep 26, 2010
    #6
    are you sure there isn't a disc in there that the system cant read so it seems like its empty?
     
  7. ebenfarnworth macrumors newbie

    Joined:
    May 29, 2011
    #7
    Can not insert CD in to a macbook pro's cd/dvd drive

    I had this problem yesterday. I look everyone on the net for a way of fixing it.

    Credit card, no good

    reseting lots of setting, no good

    There is a thing that slides across the drive from front to back that was stuck and stopping me from inserting a cd.

    decided to try cutting an old cd in haft so I could put it inside deeper than a credit card and us used the terminal command - drutil eject to hit eject many time so I could fell what was happening in side. I tried pushing the pin from the bottom back towards the screen but it did not go. I then tried from the top down and after a few trice it moved to the middle and then all the way down out of the way! Then I put a cd in and everything work! Now it's back to normal. to do this you need anything small in width than a credit card and push the pin away from the screen well using the command v to past the drutil eject into the terminal.

    Good luck and if you brake your drive doing this done come complaining as the proper way to sort this is to take you mac to an apple store and get them to doing....
     
  8. skeenastreet macrumors newbie

    Joined:
    May 21, 2012
    Location:
    West coast of British Columbia, Canada
    #8
    can't insert dvd in macbook pro

    I had the same problem and found on the Apple support forum the answer that solved it for me. Had to reset the System Management Controller.
    http://support.apple.com/kb/HT3964?viewlocale=en_US
    The way they described this is: "The System Management Controller (SMC) is responsible for many low-level functions on Intel-based Macs."
    There is a set of instructions on that page for three different systems. My laptop has a battery I cannot remove so the instructions were totally different than for a one where you can remove the battery, or mac mini and so on.
    cheers.
    Nicole
     
  9. hkshukla macrumors newbie

    Joined:
    Aug 14, 2013
    #9
    CD not getting inserted

    I had the same problem and got it done by method suggested by ebenfarnworth.
    Thanks a lot
     
  10. Lele1 macrumors newbie

    Joined:
    Oct 30, 2013
    #10
    Thank you so much @ ebenfarnworth!!!
    I have a MacBook Pro (2010) and had the same problem: no more way to insert a DVD in the slot (with no other disk jammed in the slot).
    Your suggestion is the only thing that worked for me...and I tried many!
    With your method I had to move forth and back the cut DVD in the slot while sending the eject command in the terminal...and finally it worked and got the pin out of the way! Now the DVD slot is ok!

    Thanks again.
    Emanuele
     
  11. Matacarvalho macrumors member

    Joined:
    Jun 4, 2013
    #11
    Do you have a retina macbook?
     
  12. Yahooligan macrumors 6502a

    Yahooligan

    Joined:
    Aug 7, 2011
    Location:
    Illinois
    #12
    :rolleyes:
     
  13. mikethebigo macrumors 68000

    Joined:
    May 25, 2009
    #13
    Was going to post the same smartass comment ;)
     
  14. Yahooligan macrumors 6502a

    Yahooligan

    Joined:
    Aug 7, 2011
    Location:
    Illinois
    #14
    Good thing you didn't and let the other poster make the mistake of not paying attention to the date of the original post. ;)
     
  15. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #15
    drutil tray (open | close | eject)

    Great hint, thanks!

    MacBookPro5,2 here, sometimes I find that a restart of the Mac will work around the problem – will allow insertion of a disc in the empty drive.

    Today, without restarting the Mac, I tried the eject verb five times.

    The first try seemed to make the drive less ready to accept a disc; less of the disc could be introduced. After five successive attempts I experimented with different uses of the tray verb.

    For reference only, here's the sequence of commands that worked around the problem on this occasion:

    Code:
    drutil eject
    drutil eject
    drutil eject
    drutil eject
    drutil tray eject
    drutil tray close
    drutil tray open
    drutil tray eject
    drutil tray open
    drutil tray eject
    YMMV

    drutil(1) Mac OS X Manual Page
     
  16. a-m-k macrumors 6502a

    a-m-k

    Joined:
    Sep 3, 2009
    #16
    I'm curious, OP, yes, I realize this is a very old thread, and I am almost sure this was posted the same year that I had a similar problem. Did you have your slot drive replaced, and on an unrelated note, but since it happened to me, it may have happened to you.... Was your keyboard replaced.

    On my old MBP that I don't own anymore. I ended up replacing the keyboard, the slot drive, and I think the top case. (I never figured out why the top case was replaced.)

    I hope you have better luck with this problem than I had with my old MBP.
     
  17. Nick Jinks macrumors member

    Joined:
    Aug 17, 2010
    #17
    Thanks grahamperrin, that set of commands helped fix mine. [Mid-2009 Macbook Pro 13.3]

    It was stuck in the "eject" position I think, was almost ready to take it to the shop. Had already tried resetting the SMC without success.
     

Share This Page