Cant instal WIN 7 via bootcamp - pls help

Discussion in 'Windows, Linux & Others on the Mac' started by soladood, Jun 17, 2014.

  1. soladood macrumors newbie

    Joined:
    Jun 15, 2014
    #1
    hi

    Recently I have been trying to instal win7 on my macbookpro but keep getting a prompt to instal DVD SATA drivers.

    I did some research already and this is not a problem specific to Mac installations - its a microsoft issue.

    The issue is normally fixed by downloading intel chipset 6 series SATA drivers (or whatever the PC motherboard requires). These installers come as an exe file and isn't an issue installing on a PC.

    On a mac however - this is a problem - when using bootcamp under OSX.

    Im trying to figure the workaround but cant find specific tutorials on this.

    My gear is:
    OSX 10.7.5
    Macbookpro 13.1" 2.3 GHz dual core i5 with 4gig RAM (early 2011)
    Bootcamp 4.0.4


    Ive downloaded the win7 iso - thats as far as ive got.

    My question really is where to find a download of SATA drivers for my motherboard. Intel has all the drivers listed but are specific to PC hardware. Macs dont get a listing:(

    The driver has to be like a DLL file (or similar) not a exe installer cause the mac still doesn't have windows installed to run it.

    Maybe make a partition of MSDOS then run the exe in terminal might be the way forward but I do need help in this area.

    Any suggestions would be much appreciated:)
     
  2. saturnotaku macrumors 68000

    Joined:
    Mar 4, 2013
    #2
    Burn the .iso to a DVD on a Windows machine, put the DVD in your SuperDrive, run Boot Camp Assistant, and follow the prompts. OS X will create the partition, and reboot from the Windows DVD. No prompting for drivers of any kind.
     
  3. soladood thread starter macrumors newbie

    Joined:
    Jun 15, 2014
    #3

    Ive already done that - the windows start to instal - started filling out details etc - then the DVD driver error shows up.

    Like i said this is not a mac issue - its a win7 issue - same thing happens on another older PC laptop - the error is common when installing win7 on older series hardware - many people have listed it on google - but they are all PC users - i just haven't found anyone that tried to get around it on bootcamp - yet:)
     
  4. saturnotaku macrumors 68000

    Joined:
    Mar 4, 2013
    #4
    My Mac is the same age as yours, and I've installed Windows 7 Home Premium, Professional, and Ultimate on it without any issues whatsoever.

    This leads me to believe one of three scenarios:

    1) You are attempting to use a slightly older build of Windows or one that does not contain Service Pack 1 already on it.

    2) You are attempting to install a 32-bit version of Windows when Boot Camp supports 64-bit only.

    3) Your .ISO file was obtained from a less-than-legitimate source.
     
  5. soladood, Jun 19, 2014
    Last edited: Jun 19, 2014

    soladood thread starter macrumors newbie

    Joined:
    Jun 15, 2014
    #6
    I got the download from digitalriver.com (the official microsoft download site) with the intentions of buying the licence.

    What you have explained is all stuff that is correct - but this issue goes beyond all that:)

    I am wanting to install WIN7 32 bit on my macbook (mine is early 2011, yours is late2011 - they are slightly different)

    I run 10.7.5 which is a 32bit OS:) I could upgrade to 10.8 but thats 64 bit and might play havoc with some of the older apps I'm still running. Besides I just bought a new mac mini with maverick for other things - i just need to run windows on my older machine to run my pc software that still runs on XP - but my PC is about to die - hence the urgency here!

    Anyway Ive just booked into a session with the mac gurus at their store for saturday to help with this. So far the only workaround is to bypass the DVD install and just ISO burn a usb drive - but with that method you still need to edit the BIOS settings (in a PC setup) - there is a way to Terminal the same with macs but I'm just not up on UNIX to do it properly:)

    I appreciate your thoughts though!

    ----------

    I'll give it a try - already tried 2 download sources though...tnx
     
  6. saturnotaku macrumors 68000

    Joined:
    Mar 4, 2013
    #7
    Aside from slight bumps in CPU and GPU power, all 2011 machines are otherwise identical. Same logical board chipset, same RAM support, same operating system support. My system originally came with 10.7.5 installed on it, and I purchased it brand new in July 2012 (it was new old-stock).

    Aside from some very old, company specific proprietary software, there is nothing I can run in 32-bit Windows that won't run in a 64-bit environment. However, Windows 7 Professional and Ultimate come with a built-in virtual machine program that will download and install a free copy of XP that you can run. It's similar to what Parallels and VMWare do in OS X, but you don't have to pony up for a separate Windows license.

    All what you're describing does is open up a check box in Boot Camp Assistant that is grayed out on machines that have a SuperDrive. It will not, in fact, let you perform a Windows installation via a USB flash drive.

    If you have access to another Windows computer, try burning the .ISO to a DVD there, rather than attempting to do so with Disk Utility or another OS X burning program.
     
  7. soladood thread starter macrumors newbie

    Joined:
    Jun 15, 2014
    #8
    Thanks for your reply - just a quick update:

    - your rig and mine are different - yours is a quad - mine is a dual - different drivers:)

    - you can burn an ISO onto a USB - just not on my version of bootcamp:)
    - i founds a workaround to that - unpack the iso in disk utils - copy and paste the unpacked files to a USB - problem solved!

    - as far as the win7 error not picking up the SATA drivers on instal, it is a microsoft problem - not a mac - the same thing happens on my old DELL that runs XP - my problem is not unique - many older pc owners are suffering the same - yet to find someone with my vers of mac, OS, Bootcamp etc - I must be the only one - hahaha!

    As far as running 32 bit software on a 64bit machine - sure - it works - performance reduced though - thats normal though - as a developer myself (embedded coding), dual cores dont really cut it with 64bit apps - they can but I run high end audio hardware and it needs all the optimized coding it can get - which is usually the OS vers that the processor comes with out of the packet - which in my case was 10.6.8.



    Like Ive even consulted with a mac guru on this - its left him speechless - he knows the problem - but getting access to processor drivers and for other chipset is not the done thing it seems - apple have well and truly locked the door on that.

    Appreciate your time on this - but this is something that goes a bit deeper I'm afraid.

    I do know a guy from years ago that used to code OS's for companies - maybe he can help:)

    cheers
     

Share This Page