Can't install 2.0.1 update. "unknown error" -19

Discussion in 'iPhone Tips, Help and Troubleshooting' started by BackFocus, Aug 5, 2008.

  1. BackFocus macrumors member

    Joined:
    Jul 12, 2008
    Location:
    PA
    #1
    I can't install the new update, whenever I hit 'update" it comes up with an error message

    "iTunes could not sync to the iPhone because an unknown error occurred (-19)"

    funny its "unknown", yet they have a number for it :p

    any ideas? I've got the netshare app and I dont want to do a full restore :/
     
  2. roqstar macrumors newbie

    Joined:
    Aug 5, 2008
    #2
    me too :(

    unknown error -19.

    i too have netshare but only in my itunes - still hadn't sync'd it to my iphone...
     
  3. TheScavenger macrumors regular

    Joined:
    Jul 14, 2007
    Location:
    Kansas City, MO
  4. antel0pe macrumors newbie

    Joined:
    Jan 22, 2008
    #4
    Same issue, no NetShare here. Might to a full restore, but basically every OS update is a full restore on these devices I believe...
     
  5. davyreins macrumors 6502

    Joined:
    Jul 10, 2008
    Location:
    Ann Arbor
    #5
    Same thing happened to me. I just ejected and unplugged my iphone and then plugged it back in. After that it worked...don't know why.
     
  6. gadgetdad macrumors 6502a

    gadgetdad

    Joined:
    Sep 10, 2007
    Location:
    On my iPhone
    #6

    I bought netshare and then deleted all my apps. I figured I could just redownload it. Come to find out Apple removed it from the store. Then I checked my trash bin on my mac, and there it was as a IPA file. I just dragged it over to itunes and it loaded back up on my iphone.
     
  7. jhartstein macrumors newbie

    Joined:
    Jul 5, 2007
    #7
    2.0.2 now working

    I had the same issue trying to get the latest firmware on the iPhone. After unplugging it from my MacBook and trying to install it again it worked.
     
  8. kanakc macrumors newbie

    Joined:
    Aug 18, 2008
    #8
    Unknown Error (-19)

    I got the same error (-19) after I downloaded the 2.0.2 update. Eject, unplug, disable auto-backup and re-plug iPhone - it should work. Good luck.
     

Share This Page