Can't install Boot Camp 3.1.3

Discussion in 'Windows, Linux & Others on the Mac' started by PhoenixRising18, Jul 20, 2010.

  1. PhoenixRising18 macrumors newbie

    Joined:
    Jul 20, 2010
    #1
    I have a new MacBook Pro 13-inch mid-2010 model, and I noticed that when I am in Windows 7 and try to use my headphones through the audio jack, I get no sound. I looked on Apple's website, found the 3.1.3 patch which claims will fix headphone sound, downloaded it, but when I went to install it, I got this error:

    "The upgrade patch cannot be installed by the Windows Installer service because the program to be upgraded may be missing, or the upgrade patch may update a different version of the program. Verify that the program to be upgraded exists on your computer and that you have the correct upgrade patch."

    This is frustrating because I DO have Boot Camp 3.1.0 installed, which I assume is the version needed to upgrade, and Boot Camp IS installed. I also downloaded the 32-bit version as that is the version of Windows 7 I have, and just for jollies I tried the 64-bit version but that yielded the same error.

    What am I doing wrong here? How can I install this patch? I would very much like to be able to have functional headphones. Thanks in advance!
     
  2. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #2
    Have you just run the Apple Software Updater?

    B
     
  3. PhoenixRising18 thread starter macrumors newbie

    Joined:
    Jul 20, 2010
    #3
    Yes, I have tried that, and it doesn't show any updates besides iTunes, QuickTime etc.

    I wonder though, if 3.1.0 installed correctly, when I go to the windows tray and click on bootcamp and check for more info it SAYS it's version 3.1, but when I actually go to the bootcamp application in my program files and check it's properties it seems to say it's still version 3.0.

    Any further suggestions?
     
  4. PhoenixRising18 thread starter macrumors newbie

    Joined:
    Jul 20, 2010
    #4
    Ok, so I installed drivers from the system restore disks that came with my laptop, and the error message changed, still doesn't work, but progress is good, right?

    Now it says:

    "The installed product does not match the installation source(s). Until a matching source is provided or the installed product and source are synchronized, this action can not be performed.

    Contact your administrator or product vendor for assistance. If there is a matching installation source, type it below or click Browse to locate it"

    Now, what on earth does that mean? In the test box, the default path is "C:\ProgramData\Apple\Installer Cache\Boot Camp 3.0.0\", which doesn't exist on my computer. When I click "browse" it lets me look for a .msi file, which I cannot find and do not know where to look for.

    If I click OK, another error pops up saying:

    "The file 'D:\Boot Camo\Drivers\Apple\BootCamp.msi' is not a valid installtion package for the product Boot Camp Services. Try to find the installtion package 'BootCamp.msi' in a folder from which you can install Boot Camp Services"

    Please, please, please, if anyone has any suggestions on how to fix this, Iwould be very obliged. Thanks again in advance!
     

Share This Page