Can't install boot camp sotware on XP

Discussion in 'Windows, Linux & Others on the Mac' started by Nikklaus, Jan 1, 2009.

  1. Nikklaus macrumors member

    Joined:
    Aug 9, 2007
    #1
    So...

    I've tried to install XP with boot camp on my new MBP. I've got as far as inserting the OSX disc in XP to install drivers, but all I get is a pop-up message saying the following:

    "This package requires a newer version of the Windows Installer. Do you want to update the version of the Windows Instaler on your system?"

    I click yes and it gives me a new mesage:

    "The required resource 'UPDATE' is missing"

    Then I can only click OK and nothing happens.

    Essentially all I want to do is boot OSX, but every time I reset the laptop it boots again in XP. I figure I need the boot camp software on the OSX disc to set the OSX partition as my default, but obviously I can't install it. The only reason I evenn want to install XP is so I can use Steam, but I'm not even very fussed about that. At this point I would happily erase the XP partition completely.

    I have backed up all my important stuff but I really really reeeeally don't want to have to reformat the whole thing.

    Cheers for reading
     
  2. Tallest Skil macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #2
    Hold Option after the boot chime to be able to go to OS X.
     
  3. Nikklaus thread starter macrumors member

    Joined:
    Aug 9, 2007
    #3
    Oh man thanks very much! Worked straight away.
     
  4. Nikklaus thread starter macrumors member

    Joined:
    Aug 9, 2007
    #4
    Sorry, just one more thing.

    I'm now removing the XP partition. It's been going for about an hour now and there seems to be no progress on the status bar (either that or the bar constantly shows the 'wave' animation). But yeah, I didn't expect it to take this long, is this normal?
     
  5. Markov macrumors 6502

    Markov

    Joined:
    May 18, 2007
    Location:
    Philadelphia
    #5
    It should only take a minute or so, but sometimes boot camp will pull a microsoft and stop working. Quit out of the application and try again. If you still have issues, try rebooting (do not forget to select the correct OS) and try to remove the partition. Also, which service pack of XP do you have installed?
     

Share This Page