Can't Install Canon PIXMA iP5200

Discussion in 'Mac Basics and Help' started by netdog, Feb 22, 2007.

  1. netdog macrumors 603


    Feb 6, 2006
    Intel Mac with 10.4.8. I install the drivers from Canon's website and when I reboot and go to System Preferences and add a printer, I see the printer itself just fine, but I can't find the correctly marked driver. Is there another name for the driver for this Canon? I don't have the original CDs for the printer anymore.

  2. MacBoobsPro macrumors 603


    Jan 10, 2006
    Have you tried using the printer without installing the drivers?

    You may find that OSX already has a driver for it and by you installing Canons version it is causing a conflict.

    I have an Epson printer and a Canon scanner (among other stuff) that I dont need any drivers for. Just plug em in and they work.

    Try uninstalling and first see if it work without.
  3. netdog thread starter macrumors 603


    Feb 6, 2006
    Nope, that didn't work.

    Also, there are lots of Canon drivers listed, just nothing with 5200. Are there other Canon drivers that would work with this printer? Could anybody email a valid driver and tell me what folder to drop it in?

  4. khundick macrumors newbie

    Mar 30, 2007

    im having similar probs. so i tried the 6200 driver and i can print cd's, but when i go to print a full page a4 photo, it prints it in 4x6.
  5. diamond3 macrumors 6502a

    Oct 6, 2005
    Well, I had this similar problem it sounds like. I could get the iMac to see that the printer was connected, but it couldnt find the driver even after i installed it from the cd, uninstalled it with removing the packages etc and then reinstalling it.

    After all of this, I ended up getting out the original discs and then reinstalled the system.

    View this thread. There is more detail to my post there.
  6. PatrickF macrumors 6502

    Feb 16, 2006
    I've had no problems getting a 4300 to work, which probably uses the same driver as the printers are so similar.

    I just installed the drivers off Canon's site and plugged the printer in via USB - nothing more needs to be done. You can't use these drivers to print to a network printer by the way, they only support local printing via USB.

Share This Page