Can't install "ClickToFlash" or "ClickToPlugin"

Discussion in 'OS X El Capitan (10.11)' started by Fishrrman, Apr 10, 2016.

  1. Fishrrman, Apr 10, 2016
    Last edited: Apr 10, 2016

    Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #1
    Hardware: late-2012 Mac Mini
    OS: El Capitan 10.11.4 (SIP is DISabled)
    Safari 9.1 (only user-installed extension is AdBlock 2.54)

    I'm trying to install either "ClickToFlash" or "ClickToPlugin", and neither one will install.

    What I'm doing:
    - download either extension to the desktop
    - double-click the ".safariextz" file to launch installer
    - dialog box appears: "Are you sure you want to install the extension "ClickToPlugin" ?
    - I click the "Trust" button...and...
    - nothing.
    At this point, the Safari "extensions" pref pane is displayed, but nothing new has been added.

    What am I doing wrong?

    RESOLVED!

    A little more investigating found the solution.

    These extensions won't install UNLESS you reboot into Safe Mode first.

    Don't know why that is, but it is what it is.

    ALSO...

    I previously had Safari Technology Preview installed.

    After booting to Safe Mode, I double-clicked the extensions, and... instead of installing into Safari, they installed to Safari Technology Preview instead.

    So... to get them to install into Safari, I had to first delete Safari Technology Preview.

    And I thought things like this were supposed to be EASY on the Mac.
    Ha!

    And one more thing:
    I tried to mark this thread as "resolved", but could not find the controls by which to do so.
    How do you do it?
     
  2. Shirasaki macrumors 604

    Shirasaki

    Joined:
    May 16, 2015
    #2
    A workaround is adding [resolved] into your title.
    Or, there is a dropbox when editing your post. That box is at the head of your title. You can select "resolved" from there.
     

Share This Page