Can't Install OS From USB Devices

Discussion in 'Mac Basics and Help' started by grigoriso, May 29, 2015.

  1. grigoriso macrumors newbie

    Joined:
    Sep 20, 2009
    #1
    I am having two problems with my Mac that I hope someone here will be able to assist me with. It is a late 2010 Macbook Pro, Intel Core i5, 8GB memory. Currently, it has a single partition running 10.6.8. (For several months, I had two partitions on the hard drive: the primary partition running Snow Leopard, and a smaller partition running Yosemite, so it is Yosemite capable).

    1) The first problem is that I’ve tried to update to Yosemite on the entire hard drive, but have been unable to complete a successful download of Yosemite from The App Store. I have tried twice now, and each time I get the notice “The Application could not be downloaded. The application you tried to download could not be downloaded. Check you internet connection and try again.”

    2) As a second option, I have tried to do a clean install of Snow Leopard on a single partition, but am unable to accomplish this either. The internal optical drive has not worked for some time, but I have an external optical drive; in addition, I’ve created SL installation discs on both a USB flash drive and an external hard drive. The problem is that NONE of these appear to installing. When I reboot and hold the Option key, each will appear - for example, if I have the USB flash drive plugged it, it will appear as a hard drive that I can select - but when it is selected, NOTHING happens. I get the Apple logo, but it is clear that no files are being copied to begin the installation process. The same thing happens with all three: the flash drive, the external hard drive, and the external optical drive.

    I’ve checked the hard drive with Disk Utility and it appears to be fine. Any ideas?
     
  2. Jozone macrumors 6502

    Joined:
    Jul 24, 2007
    #2
    If you are using a retail copy (as in the one with the Snow Leopard cat on it) -- your machine will NOT be able to boot from it (the problem is that you computer was released after that build of OS X was created -- its missing necessary information for your machine to boot). What you would need at this point is either the specific restore discs for your computer, or to figure out this Yosemite download issue!

    It might be worth using a friends Mac to download Yosemite, and to create a USB drive with this (free) application: http://diskmakerx.com/
     
  3. xsquid macrumors regular

    xsquid

    Joined:
    May 27, 2015
    #3
    +1 on diskmakerx, makes it quick and easy plus the bootable usb it makes works beautifully.
     
  4. grigoriso thread starter macrumors newbie

    Joined:
    Sep 20, 2009
    #4
    Yep, that's the problem; someone on another forum suggested it as well. I know I had those discs last October… oh well, keep digging.
     
  5. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #5
    OP:
    What is the final result that you wish to obtain?

    Do you want just one partition with 10.6.8 on it?
    OR.... do you want just one partition with Yosemite on it?

    What I suggest:
    (you will need an external drive)

    - Use a cloning app (either CarbonCopyCloner or SuperDuper) to clone each partition to a backup drive.
    - Boot from the backup drive and re-initialize the internal drive (note: if you are going to use Yosemite as your OS, boot from your backup copy of Yosemite)
    - Use the cloning app to RE-clone the contents of the backup drive BACK TO the single partition on the internal drive.

    Does this work for you?
    Do you now have a bootable OS on the internal drive?
     

Share This Page