Can't Install OS X on New 7200 RPM HDD

Discussion in 'Mac Basics and Help' started by street.cory, Apr 22, 2010.

  1. street.cory macrumors 6502

    street.cory

    Joined:
    Oct 13, 2009
    #1
    Okay, So I have a Late 2009 15.4 inch 2.53 GHZ Unibody MBP with 4 GB of RAM and a 5400 RPM 250 GB Drive. After upgrading to Snow Leopard and experiencing bugginess I switched back to Leopard. I then thought that a 7200 RPM drive would be a nice upgrade so I ordered one on Newegg ($45!!). It's a Hitachi 250 GB 7200 RPM (HDD:7K320-250)(MODEL:HTS723225L9A360). SOO getting to the problem...

    I shutdown my laptop, removed the my drive, popped the new one in (took out the plug screws and placed in new drive so it didn't go anywhere) screwed everything down, popped in my 10.5.7 DVD and booted from disc. Great. I notice that no HDD's were listed to install the OS on so I went to Disk Utility, found the drive, tried to format it in HFS Jounaled and it failed (some write error). Confused, I restart and try again with my DVD. Same thing. I pop my old one back in, it boots up fine, plug my new one in with a sata-usb cord and it says it can't be read. I open up disk utility, format it, and can use it as an external and use it with Time Machine. Weird.

    I then erase the drive to HFS Journaled and successfully install the OS on my new drive via USB, boots up fine, but when i place it in the MBP and try to boot up... nothing.. try to reinstall.. nothing.. reformat.. nothing. I am at my wits end at what to do.

    Please help! Do i need to send my drive back to newegg or am i overlooking something? anything I can try? I hate unscrewing all these dang screws! lol.

    Thanks in advance
     
  2. HBOC macrumors 68020

    Joined:
    Oct 14, 2008
    Location:
    SLC
    #2
    well atleast you don't have a non unibody, like i do. Imagine having to take the casing off everytime:cool:

    As far as your OSX problem goes, when i upgraded from leopard, i re-formatted, re-installed leopard and then installed SL, and didn't have a single problem. What kind of buginess did you encounter?

    Now this may be the same thing, but i formatted my 500Gb 7200 Hitachi in OS Journalized. I am unsure if that is the same as HFS? I put mine in, formatted it and it has worked problemo free for some 6 months.
     
  3. street.cory thread starter macrumors 6502

    street.cory

    Joined:
    Oct 13, 2009
    #3
    Yeah HFS is the type of filesystem apple uses. I did use mac os x extended (journaled) and it worked as a time machine backup disk. So i re-erased it no problems and tried to install os x (10.5 & 10.6) by hooking it up inside the machine. no dice. the os x disc i am using (10.5) works fine, the proof is that it's the same disc that installed the OS i'm on right now. The problems i had with 10.6.3 were the intermittent wireless connection, often random program crashes, decreased performance in iphoto (full screen editing and zooming) slow imovie loading. it wasn't TOO bad. but the things that sound minor really frustrated me. I'm back in business with leopard but wanted to try 10.6 on another hdd, the 7200. the problem is i can't get it installed. it fails to install and when i restart to try again, it fails to recognize the drive as an installable device. then it fails to format via mac os x boot disc. I did get it to install via usb though.. i'm really confused!
     
  4. psxguru macrumors 6502a

    Joined:
    May 19, 2006
    #4
    I wonder if it's the same problem myself and plenty of others encountered, although the majority of people had problems with a Western Digital 320Gb drive (WD3200BEVT). The SL installer won't recognise certain drives as an install option.
     
  5. bmcgonag macrumors 65816

    bmcgonag

    Joined:
    Mar 20, 2007
    Location:
    Texas
    #5
    Use your current install, and Carbon Copy Cloner to Clone the current HDD as a bootable clone to the new HDD.

    Re-insert current HDD in MBP. Connect New HDD with USB. Clone entire disk as bootable.

    Then you just switch them and reboot.

    I"ve done this several times to get a bigger drive into my MBP, MB, and iMac.

    Best,

    Brian
     
  6. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #6
    In Disk Utility, select the drive, then click the Partition tab.

    Choose the Volume Scheme you want (must be something other than Current). This will enable the Options... button.

    Click the Options.. button and choose GUID Partition. It's quite likely that Master Boot Record will be what you have now.

    The right partition scheme is mandatory for a bootable drive. If the partition scheme is wrong, it won't matter if the disk volume is HFS+ Journaled. It still won't boot.

    I have done this several times on several different hard drives, including the exact Hitachi model cited.

    The other suggestion I have is simpler: don't install it inside the computer until AFTER you've confirmed you can boot from it. Confirm before install.
     
  7. street.cory thread starter macrumors 6502

    street.cory

    Joined:
    Oct 13, 2009
    #7
    Okay, So...

    psxguru, i believe the issue for me is something with the drive, i've used leo and SL and they both won't find a drive, OR can't successfully reformat the drive, OR cannot install the OS on the drive

    bmcgonag, I tried Carbon Copy Cloner and this time it didn't work. (I've used it before when i did a fresh SL install in February.) Once the copy was completed, and it was verified that it would be a bootable drive, I plugged it in to the mbp and it had some kernel panic looking screen. so i restarted and then it just sat there and kept trying to load and load and load. I left it for an hour and nothing ever came of it. In fact, it went grey.

    Chown33, When I erased it the first time i did make sure that it was GUID and said it would be a bootable drive. I plugged it in, started to install both leopard (failed) and snow leopard (failed) and they both failed.

    Thank you for all of your help, i hope i can get a replacement from Newegg. Has anyone done that before? will I have to pay for return shipping??
     
  8. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #8
    The best way to answer the shipping question is to contact Newegg directly. Frankly, I'm surprised you haven't already done that. If I received a hard drive that didn't work, I'd contact the vendor first, not last.
     

Share This Page