Can't install Perian - permissions issue - plz help

Discussion in 'macOS' started by jon08, Jan 2, 2010.

  1. jon08 macrumors 65816

    Joined:
    Nov 14, 2008
    #1
    So I decided to install Perian today on my SL 10.6.2. I ran it and it created an icon in the Pref Pane, but when I clicked on the icon and then hit the Install button, nothing happened. I tried it several times and even restarted my MBP, but still nothing.

    I then tried opening Console to see what happens when I hit the Install button in Perian, and I saw several msgs saying Permission Denied.

    What the heck is this? I've already experienced some permissions issues lately when I tried to copy mp3s onto my USB key, so I ran the OnyX maintenance just yesterday - but to no avail. I still can't copy most of my mp3s onto USB. And I don't really see a reason why I should repair permissions ONCE AGAIN today just because of Perian??

    What's going on? I really don't get this Mac OS permissions crap. I am the only user on this computer and am therefore an Admin, so what is all the fuss about permissions?? How can I fix this mess?
     
  2. jon08 thread starter macrumors 65816

    Joined:
    Nov 14, 2008
    #2
    Update: I just repaired permissions, and as expected it didn't help.

    Update2: I manually set both Home and Macintosh HD QuickTIme folders in Library to Read & Write in both categories, and this seemed to have helped. Interesting. Is there a way to make everything my MBP Read & Write by default? Or is it better for the security sake not to have it in that way?
     
  3. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #3
    It is better that you don't make everything read&write by default. It is also odd that you wouldn't have write permission to those folders... as an administrator, you're supposed to have write access by default to both.
     
  4. jon08 thread starter macrumors 65816

    Joined:
    Nov 14, 2008
    #4
    Which is exactly why all this pisses me off. I really have no clue why the heck I didn't have access before. Is there a way to make all permissions (Read & Write thing) set to the default setting? Because repairing permissions didn't seem to fix anything.
     
  5. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #5
    Yes, that's to be expected regarding repairing permissions. All that function does is check the permissions on the disk and compare them against the permissions specified in the installation package receipts. If they don't match, then the permissions get changed to match what the receipts specify. This process will NOT affect your user folder, nor will it affect many other folders on your disk. It just so happens that the two folders you're working with are not affected by Repair Permissions.

    Anyway, you really DON'T want to do that - make everything read&write by default, that is. It's terrible security, for one thing... and the Repair Permissions function will change many folders back, anyhow. It sounds to me like there's more to this problem than meets the eye. Have you ever used the chmod command in the Terminal? If you have, and didn't know what you were doing... that could easily cause the problems you're having.
     
  6. jon08 thread starter macrumors 65816

    Joined:
    Nov 14, 2008
    #6
    I see, thanks. What is chmod command tho?
     
  7. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #7
    chmod is short for change mode. Modes in UNIX are just another name for permissions. You can do all sorts of permission-related things with this command, including ACL (access control list) manipulation.
     
  8. jon08 thread starter macrumors 65816

    Joined:
    Nov 14, 2008
    #8
    Oh, then I guess I didn't change anything related to chmod... What would you advise me to do regarding the Read & Write thing tho? How should I set it for my Macintosh HD & Home folders? Anything else I should do?
     

Share This Page