can't install spotify on my ipod iOS 9.3.5

Discussion in 'iPod touch' started by michel52, May 29, 2019.

  1. michel52, May 29, 2019
    Last edited: May 29, 2019

    michel52 macrumors member

    michel52

    Joined:
    Sep 1, 2012
    #1
    guy's i can't install spotify on my ipod touch generation 5, is there any solution to fixed it?
    :eek:
     
  2. Howard Ellacott macrumors member

    Howard Ellacott

    Joined:
    Jun 10, 2012
    Location:
    United Kingdom
    #2
    It's probably to old for the current version. If you sign in to a newer device with your apple ID and download spotify, you should be able to then download an old version on your iPod. If you haven't got another device, use the app version of iTunes: https://support.apple.com/en-gb/HT208079
     
  3. michel52, May 30, 2019
    Last edited: May 30, 2019

    michel52 thread starter macrumors member

    michel52

    Joined:
    Sep 1, 2012
    #3
    i don't understand it what i have to do , must iTunes installed on my mac mini or my ipod cause my ipod have already iTunes ?
    its not clearly for me about the link you gave ....
     
  4. Howard Ellacott macrumors member

    Howard Ellacott

    Joined:
    Jun 10, 2012
    Location:
    United Kingdom
    #4
    You have to have Spotify as a purchase on your Apple Account. You can only download it onto your iPod if you have already downloaded it somewhere else, on a newer device that is running iOS 10, or an iTunes install that is older than 12.6. Once you've downloaded it somewhere else, it will show up in the App Store with a cloud icon and an arrow coming out of it (see screenshot).

    If you don't have another device, you have to use the special version of iTunes which still has the app store to add it to your account, which is in the previous link I sent.
     

    Attached Files:

  5. michel52 thread starter macrumors member

    michel52

    Joined:
    Sep 1, 2012
    #5
    i did sign in with my apple ID from my mac mini (high sierra 10.13.6 ) with my ipod touch 5 and i don't see an older version of spotify in the appstore ... i have installed spotify on my mac mini but not with the appstore cos there is no spotify app to find ???
     

    Attached Files:

  6. Howard Ellacott macrumors member

    Howard Ellacott

    Joined:
    Jun 10, 2012
    Location:
    United Kingdom
    #6
    So by newer device it’s got to be a newer iOS device. If you’re going to use a Mac, you have to look in the iOS AppStore that’s in the old version of iTunes. You’ve looked in the mac App Store which is a different thing!
     
  7. michel52 thread starter macrumors member

    michel52

    Joined:
    Sep 1, 2012
    #7
    can you explain me how i can find the iOS Appstore to use a mac?
    i search already in the appstore from my ipod touch 5 and into the appstore from my mac .... nothing there!
     
  8. mxnut macrumors newbie

    Joined:
    Jun 23, 2010
    Location:
    Oxnard,CA
    #8
    I’m having the same problem with the Pandora app. Says it is not compatible. I have it on a different iPhone and IPad running the latest iOS and when I go and try and download it for the iPod running 9.3.5 it says it is not compatible. I have the little down arrow and the cloud icon but like I said when I click on it I get the same message.
     
  9. spyguy10709 macrumors 6502a

    spyguy10709

    Joined:
    Apr 5, 2010
    Location:
    One Infinite Loop, Cupertino CA
    #9
    You have to use an older version of itunes that still has the iOS appstore, apple has removed it in newer updates. https://support.apple.com/en-us/HT208079 use this special version to roll back permanently to this older version of itunes.

    From there, search the app store within itunes for spotify. "purchase" it on your mac. Then you should be able to download the last compatible version on your ipod touch
     
  10. Plutonius macrumors 604

    Plutonius

    Joined:
    Feb 22, 2003
    Location:
    New Hampshire, USA
    #10
    or just get a newer Touch ?
     
  11. michel52 thread starter macrumors member

    michel52

    Joined:
    Sep 1, 2012
    #11
    sorry but i don't understand how you get to that point , cause when i check it at the app store from my ipod 5 touch to look for iTunes,its not available .... so how can i roll back if its not there to download it???
     
  12. spyguy10709 macrumors 6502a

    spyguy10709

    Joined:
    Apr 5, 2010
    Location:
    One Infinite Loop, Cupertino CA
    #12
    " cause when i check it at the app store from my ipod 5 touch to look for iTunes"

    ??

    Download itunes 12.6.3 on a MAC COMPUTER, use itunes on the MAC (not the ipod) to open the app store.
     
  13. michel52 thread starter macrumors member

    michel52

    Joined:
    Sep 1, 2012
    #13
    Okey i download iTunes 12.6.3 i install it and now my itunes on my mac don't work anymore !!!!
     
  14. michel52 thread starter macrumors member

    michel52

    Joined:
    Sep 1, 2012
    #14
    after this i google a bit about this problem and fix it again, to change the name itune libary .itl to itune libary bak.itl
     

Share This Page

13 May 29, 2019