Can't install updates on my mac!

Discussion in 'iMac' started by RMS44, Oct 23, 2010.

  1. RMS44 macrumors newbie

    Joined:
    Oct 23, 2010
    #1
    I have a mac OSX version 10.5.8 and i was trying to install the ilife 11 i just bought and was super excited about but when i tryed to download ilife 11 it said i needed to update my computer, so i went and downloaded the updates but my mac still says its the same version!:( :eek: and ilife wont install... I tried to go back and install the updates again but there not there it says I'm all updated! but 10.5.8 is not the latest version right ? What should I do? :confused:

    Thanks!! Robert
     
  2. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #2
    You need OS X 10.6.3 or later, 10.5.8 won't cut it.

     
  3. RMS44 thread starter macrumors newbie

    Joined:
    Oct 23, 2010
    #3
    Yeah I know! Thats why im trying to download the new updates... but it wont let me??
     
  4. C. Alan macrumors 6502

    Joined:
    Jan 23, 2009
    #4
    You need buy Snow Leopard (10.6) and install it. Then you can get download the upgrade to 10.6.3
     
  5. RMS44 thread starter macrumors newbie

    Joined:
    Oct 23, 2010

Share This Page