Can't install WC3 Frozen Throne on OSX

Discussion in 'Mac and PC Games' started by Kaiserman, Mar 3, 2011.

  1. Kaiserman macrumors newbie

    Joined:
    Mar 3, 2011
    #1
    Hi everyone, first post here.

    I have RoC installed, fully patched and running just fine but when I put in the Frozen Throne CD it tells me that I have to install RoC first. It doesn't seem to be registering that it's already installed. I tried uninstalling and reinstalling a few times but still no luck :(

    It's definately not the disc as I installed it on my Windows partition and it works just fine, it's just a pain in the ass to reboot every time I want to play it, and there's no reason why I should have to.

    Anyone? Much appriciated. :)
     
  2. zbeebs macrumors newbie

    Joined:
    Sep 9, 2008
    #2
    I don't know if this will work specifically with WC3, but it's worked on my other Blizzard games. Go to Battle.net and create an account (if you don't already have one) and register your game using the codes from your disks. Once you've registered, Blizzard let's you download and install the game directly from their site without using the install disks at all.
     
  3. bokdol macrumors 6502a

    bokdol

    Joined:
    Jul 23, 2002
    Location:
    VA
    #3
    the best way to get ft to install is to upload your serial numbers to blizzard. by making a battle.net account. once uploaded you can download the full installers of all the games you own. it's a nice way to keep track of all your games.

    edit: damn. beat me to it.
     
  4. Kaiserman thread starter macrumors newbie

    Joined:
    Mar 3, 2011
    #4
    Excellent idea! Thanks a million. Done it now and it seems to be working; I didn't know WC3 was part of the new B.Net. :D
     

Share This Page