Can't install Win 7 Pro on Boot Camp due to "Setup was unable to create a new sys..."

Discussion in 'Windows, Linux & Others on the Mac' started by davechong, Jan 15, 2012.

  1. davechong, Jan 15, 2012
    Last edited: Jan 15, 2012

    davechong macrumors newbie

    Joined:
    Jan 15, 2012
    #1
    Hi Guys,

    I'm trying to install Windows 7 Professional (32-bit) on my MacBook Air (running on latest version of Lion) via USB flash drive, all using Boot Camp Assistant.

    I've managed to get Windows installer to run, but encountered the following error message after selecting the BOOTCAMP partition to install onto:

    "Setup was unable to create a new system partition or locate an existing system partition."

    I've tried some of the solutions that others have recommended in other threads, but none seem to work:
    1. Format the BOOTCAMP partition from within the Windows installer.
    2. Unplug all USB devices (except the USB flash drive that the Windows installer is on).
    3. Restart my MBA and go through the Windows installation process all over again.

    My MBA currently have the following partitions (after creating one for Windows via Boot Camp Assistant):
    1. Disk 0 Partition 1
    2. Disk 0 Partition 2
    3. Disk 0 Partition 3
    4. Disk 0 Partition 4: This is the BOOTCAMP partition.

    Hope someone can help me with this. I've spent many hours trying to figure this out, with no luck. :(
     
  2. davechong thread starter macrumors newbie

    Joined:
    Jan 15, 2012
  3. johnhurley macrumors 6502a

    johnhurley

    Joined:
    Aug 29, 2011
    #3
    Have you tried win 7 64 bit? Maybe something funky about a win 7 32 bit install?
     
  4. davechong thread starter macrumors newbie

    Joined:
    Jan 15, 2012
    #4
    I've just managed to install it using a borrowed external DVD drive. :)
     
  5. mde1 macrumors newbie

    Joined:
    Feb 29, 2012
    #5
    Same here- switching usb drive helped

    I had the same problem-- it was driving me nuts. I ended up testing a different USB flash drive, and it worked without a hitch. The one that didn't work was a Lexar 8gb swivel drive (even though an identical one has worked before)-- and the new one was a 4gb Verbatim-- it worked perfectly.

    Also-- you don't have to make the USB manually anymore. Microsoft has a free Win 7 USB maker tool for download. :eek:
     
  6. sbeckstead macrumors newbie

    Joined:
    May 22, 2012
    #6
    Solution

    What worked for me was to put the windows install image on the desktop and check all three boxes (build usb, download support, install) and allow it to run through to completion it seems that there are files in the support package that overwrite the files in the installer and allow a different bootmgr to be installed that handles the weird bootcamp restrictions/problems.
     

Share This Page