Can't install windows 7- bootcamp

Discussion in 'Windows, Linux & Others on the Mac' started by youssefm, Nov 1, 2014.

  1. youssefm macrumors 6502

    Joined:
    Oct 7, 2008
    #1
    Hi everyone!

    I have a mid-2009 15” macbook pro (2.66ghz, 4gb ram). I just upgraded to Yosemite and now I’m having tons of trouble installing windows 7 via bootcamp.

    I used bootcamp to create the partition, everything loaded up and when I get to the windows installation screen (I choose my location and language) then I get this error: “A required CD/DVD drive device driver is missing. If you have a driver floppy disk, CD, DVD, or USB flash drive, please insert it now.” I know this shouldn’t be happening but I inserted my driver flash drive but none of the drivers are correct, and I can’t even install windows or get past this page.

    I read that maybe my ISO was corrupt, so I burned another copy (tried burning at lower speeds, using a PC, I made 6 different versions of the ISO and none work). Same problem. I burned a copy of the official windows trial ISO, still same issue. I tried booting by pressing F8 and disabling signature drivers, but still have the same issue.

    So then I tried creating a bootable USB. I know my mac won’t boot from USB but I created the bootable USB using the windows 7 usb tool, I go to boot (I press C after the startup chime) but all I get is a black screen with blinking white underscore, and nothing ever loads. Then I tried hacking bootcamp via editing the info.plist and using terminal, I create a USB via bootcamp, but then I never even get to the black screen to load windows.

    Now I’m completely lost and not sure where to go from here. Does anybody have any suggestions on what I should do or what my options are?
    Will windows 8 work on my machine? Any solutions?

    Thank you!!
     
  2. macenied macrumors 6502a

    macenied

    Joined:
    Aug 20, 2014
    #2
    Your Superdrive is working ? If you can boot the DVD it seems that you burned it correctly. Try to clean the Superdrive lens using a CD/DVD lens cleaning kit.
     
  3. youssefm, Nov 2, 2014
    Last edited: Nov 2, 2014

    youssefm thread starter macrumors 6502

    Joined:
    Oct 7, 2008
    #3
    My superdrive should be working fine, it seems to work with everything else. I'll try that anyway though just in case!

    *Edit- That didn't work. I'm going to try installing windows 7 pre-SP1 and update if it works.
     
  4. youssefm thread starter macrumors 6502

    Joined:
    Oct 7, 2008
    #4
    I used a copy of windows 7 without service pack1 and it installed perfectly, then updated insde windows to sp1. This solved my issue.
     

Share This Page