Can't Install Windows 7 on Boot Camp!

Discussion in 'Windows, Linux & Others on the Mac' started by hiohokaybye, Feb 17, 2010.

  1. hiohokaybye macrumors regular

    Joined:
    Sep 17, 2007
    #1
    Hello Guys,

    I have been trying to install Windows 7 (yes, legit copy) to my Macbook Pro the whole day, but I keep on getting this error message saying "Press any key to boot from cd or dvd . . . ."

    When I press any key on the keyboard, nothing happens. I know this copy works because I've tried this on VMWare 3. (I'm going to Boot Camp of BIOSHOCK!)

    What I've Tried:
    Deleted partition, recreate partition and choose the Windows 7 disk as startup disk.
    Checked Software update already, nothing was there.

    Any help would be great, thanks!
     
  2. Matthew Yohe macrumors 68020

    Joined:
    Oct 12, 2006
    #2
    Why are you messing with the partition? Run Boot Camp Assistant.
     
  3. hiohokaybye thread starter macrumors regular

    Joined:
    Sep 17, 2007
    #3
    Sorry didn't make this clear.

    I used Boot Camp Assistant to create a 50 gb partition, then tried to install Windows 7.
     
  4. spoonerist macrumors newbie

    Joined:
    Nov 29, 2009
    #4
    Have you tried not pressing a key when that screen comes up? That screen comes up for me every time I boot up in Windows. I always just leave the computer alone when I see it (i.e. DON'T press any key) and Windows boots/installs fine.
     
  5. hiohokaybye thread starter macrumors regular

    Joined:
    Sep 17, 2007
    #5
    Also tried that :( I let it sit for around 5-10 minutes. It just sat there.
     
  6. MRU macrumors demi-god

    MRU

    Joined:
    Aug 23, 2005
    Location:
    Other
  7. Lord Adama macrumors member

    Joined:
    Nov 4, 2007
    #7
    I ran into a similar problem with win 7 x64. Try a different keyboard and see if that works. I found out by way of google that win 7 x64 and boot camp don't play nice. I used a guide similar to this. That hopefully should fix it. Is that the only error message you keep on getting? Let me know if it works.
     
  8. hiohokaybye thread starter macrumors regular

    Joined:
    Sep 17, 2007
    #8
    I've tried USB Keyboard, it just restarts the whole installation, and it goes right back to the screen, so that didn't work.

    I'm installing Windows 7 x86.
    I get a message that looks like this
    [​IMG]
     
  9. prwood macrumors newbie

    Joined:
    Jul 24, 2008
    #9
    Happened to me too with my iMac core i5

    You will find the solution under Apple support. Apparently the Windows 7 installer does not include the necessary graphics or bluetooth driver for the Mac. You will need a USB storage device or SD card.
    Good luck.
     
  10. hiohokaybye thread starter macrumors regular

    Joined:
    Sep 17, 2007
    #10
    Do you happen to have the link to the website with the update?
     
  11. ^^ CoolMacLover macrumors regular

    ^^ CoolMacLover

    Joined:
    Jun 26, 2009
    Location:
    On A Apple
    #11
    Isnt that the point of installing the drivers off the OSX disk? Then again, you'd need W7 to be installed for it to work... :rolleyes: Whats a USB or SD card going to do?
     
  12. hiohokaybye thread starter macrumors regular

    Joined:
    Sep 17, 2007
    #13
    I have a Macbook Pro (2009) not iMac. The screen didn't just go black either :confused:
     
  13. prwood macrumors newbie

    Joined:
    Jul 24, 2008
    #14
    Download the drivers to the USB or SD card storage & follow the instructions on the support page & it will work.....rolleyes back...just followed the instructions & it worked!!!
     
  14. Gepper macrumors member

    Joined:
    Dec 7, 2009
    #15
    The reason for that is because of microsoft. They didnt include default drivers that worked so you have to "inject" them into the installation. At what point do you think the Mac drivers get installed on your windows system? thats right, after the installation is done.
     
  15. stokd macrumors newbie

    Joined:
    Dec 24, 2010
    #16
    Sorry to resurrect such an old thread...I'm having the exact same problem, once setup reboots for the last time it stops at the "Press any key to boot from DVD" screen. If you press a key quickly when the screen shows up it asks you to go through the setup all over again.

    I tried the USB stick solution, it didn't work. I put the .xml file and drivers folder in the root directory, formatted the drive as MSFAT with the correct name, nothing seems to work. I'm using a 15" Macbook Pro, not iMac, from mid-2010. Is there anything else I can try?
     

Share This Page