Can't Install Windows 7 Using Bootcamp Under Mac OS X Lion

Discussion in 'MacBook Pro' started by Bosslenz, Sep 15, 2011.

  1. Bosslenz macrumors newbie

    Sep 15, 2011
    I can't be the only one having this problem. I'm a Mac Newbie but I'm good at following instructions.

    Firstly, I'm running Mac OS X v 10.7.1 on A 2011 Macbook Pro 2.3GHZ quadcore w 8g Ram, a 500g 7200 rpm HD and a 750g 7200 rpm HD in the optical drive slot.

    I keep getting the Black screen with the flashing cursor on installation of Windows 7 X64 Ultimate. Here's all the steps:

    1. I removed the wireless keyboard and mouse so there were no bluetooth problems.

    2. I created an MBRFAT boot device formatted as MS-DOS Fat32 with AutoUnattend.xml and the "drivers" folder as instructed in , (one on an SD card and one on a USB drive -- I tried to boot with the each one using the Windows 7 installation disk and still the black screen with the cursor)

    3. I followed the instructions in the Boot Camp Installation & Setup Guide. Still Black Screen.

    4. I did all of this under Mac OS X Leopard and assumed that maybe the Boot Camp Assistant was out of date. I then updated to the latest version of Leopard... still black screen.

    5. I then downloaded Lion, installed it thinking that the Bootcamp Assistant, now V4.0 was more up-to-date... black screen.

    6. Before you ask, although I'm using an external DVD drive, Bootcamp sees it and only begins when I turn it on. The doc also says I can do it with an external.

    7. And Yes, I am using a Legitimate copy of Windows 7 Ultimate 64 bit that I installed under VMWARE Fusion 3 in record time. Before starting, I completely uninstalled VMWARE including the area that held the Windows 7 partition.

    Team, I've tried to be thorough and give you a complete picture of what I've gone through this entire week and to document the process so others don't waste as much time.

    If anyone has a solution or can point something out I may have missed, thanks in advance for your help.

    And please, no drivel about "Why do you need to run Windows 7 in the first place?" Trust me, I need it.
  2. Freyqq macrumors 601

    Dec 13, 2004
    1. run bootcamp setup in osx in order to create an NTFS partition on the hard drive
    2. boot off a win 7 dvd and install bootcamp to the hard drive
  3. Bosslenz thread starter macrumors newbie

    Sep 15, 2011
    I created the Partition using Bootcamp Assistant (forgot to mention that) but Bootcamp will only create it as an MS-DOS FAT32. Of course I can go into the Disk Utility under Erase, but I can only format it either as a FAT32 or ExFAT.

    I don't see anywhere where I can specify it as a NTFS partition.
  4. phyrexia macrumors 6502a

    Sep 3, 2010
    You can't install Windows 7 onto a Fat32 partition.
  5. jenzjen macrumors 68000

    Aug 20, 2010
    When you're in the Windows setup flow, and it asks you to pick a drive, IIRC, you'll see BOOTCAMP partition but formatted as FAT. Select this drive, select reformat or something similar from one of the options below the disk image and then re-select it as the destination post format.
  6. Bosslenz thread starter macrumors newbie

    Sep 15, 2011
    I won't be able to do that because I'm not getting anywhere into Windows setup. I get the black screen on the first step of the installation.

    I suspected that FAT32 may be the culprit from my PC days but the only other PC format option available is the ExFAT.
  7. kvizzel macrumors 6502a

    Jan 15, 2011
    Maybe your Windows CD is bad?

    I had to reformat my drive too, just installed it as Custom and reformatted.
  8. AFPoster macrumors 68000

    Jul 14, 2008
    Charlotte, NC
    that's strange I installed Windows 7 via BootCamp and it's Fat32, unfortunately =(.
  9. iMacDragon macrumors 68000


    Oct 18, 2008
    I believe the issue is that USB booting of bootcamp is broken on 2011 macbook pro's, or at least, it was broken on mine when I tried it, I could only install via using internal drive.

    USB booting osx on the other hand, works fine..
  10. snaky69 macrumors 603

    Mar 14, 2008
    Windows will not boot via USB, you need physical media for it to work.
  11. Bosslenz thread starter macrumors newbie

    Sep 15, 2011
    Thanks everyone. I'm going Parallels. The music programs I was running under VMware were glitchy. I hear it's not so bad with Parallels.

    At this point, it's sounding too complicated to Bootcamp it. When I got the Mac, it was specifically for music and every musician friend of mine told me to get rid of the optical drive and replace it with another hard drive. I have no regrets.

    Take Care.
  12. Gomaaz macrumors newbie

    Aug 16, 2002
    I have exactly the same problem !

    I have also a Macbook Pro 2011 and replaced the optical drive with a second HDD where I want to install windows on.

    I just can't get around the flashing cursor to boot from CD...


    I already had windows 7 installed on my MBP Oo

    But Reinstall won't work ?

    Can anyone help plz?
  13. Mr MM macrumors 65816

    Mr MM

    Jun 29, 2011
    If you already have a windows 7 install, what you can do is to get the windows 7 iso file, mount it in windows, target it to install in the other HDD. Yeah you can install windows within windows

    If you want to extend the OSX partition you are going to need to format the HDD where its installed and install it again, any logic partition cant be extended only parted
  14. Gomaaz macrumors newbie

    Aug 16, 2002
    Nope....haven't installed windows anymore....

    I want to install it on the second HDD
    I also choosed this HDD in bootcamp and startet "installation start"

    with no luck... :/
  15. BLOCKMONSTER macrumors member

    Aug 19, 2011
    You need the superdrive back in the optical bay to get bootcamp to install Win7. I spent an entire weekend trying to figure it out without putting the superdrive back. But in the end, I fellt so stupid for wasting an entire weekend, when putting the superdrive back in only took less than 10min.
  16. iMacDragon macrumors 68000


    Oct 18, 2008
    It is frustrating through, as it's presumably a bug in apples EFI-BIOS layer, older MBP's did it fine via USB optical drive. And being as it doesn't affect their own OS, they don't seem too fussed on fixing it.
  17. BLOCKMONSTER macrumors member

    Aug 19, 2011
    Yeah. I think I had about 4hrs of total sleep from Fri to Sun. I tried so many different solutions... refit, boot usb, and a whole bunch of other crap. My brother did it on his MBA without issues and it that even frustrated me further. Yeah i think its in the EFI somewhere... MBA knows theres no superdrive, while a MBP expects there to be 1.
  18. fibrizo, Sep 18, 2011
    Last edited: Sep 18, 2011

    fibrizo macrumors 6502


    Jan 23, 2009
    Had similar issues

    Opps I didn't realize you already put the CD drive back in and installed. This seems to affect all the new core series macbooks. C2D ones didn't seem to have this issue at all. You can ignore the rest of this post
    This is just for people in the future.

    I almost had a fit installing windows 7 on my new air, with an external drive, when it worked so well before on my previous airs, previous pros and everything. I also reached the same black screen. (I've bootcamped about 7-8 macbooks of all different types at this point)

    Here's what I needed to do. Apparently, I'm not sure if this is documented or not, it appears that Bootcamp version 4.0.1 (with lion) does not allow you to install off of a CD/DVD. I know this seems strange, but I was stumped for hours, restarting, repartitioning, making new discs, etc etc. You have to go through bootcamp assistant and create the usb stick, I had another bootable usb stick I had made before which also did not work. You have to give the stupid bootcamp assistant an ISO to make the changes to the boot efi so it will boot and run.

    Your issues are multifold. Bootcamp 4.0 (on all CD drive macs) won't make the bootable usb.

    Newer Bootcamp/mac EFI does not allow you to install install off external CD/DVD hands down. You will get a black screen. (Don't get mad at me, I'm as frustrated about this as you are. It made me want to shoot my macbook air)

    REfit does not work well with LION as far as I know still.

    Bootcamp does make a fat32 partition, but when you reach the windows 7 installer, it will tell you it cannot install to that partition. At that point just tell it to format the partition (it will have an option) and it will format to ntfs and progress smoothly from that point.

    Since you are using 2 spinning disks, 500gb and 750gb, I can suggest a few things.... all of them involve putting the CD/DVD back into the laptop for install.
  19. Gomaaz macrumors newbie

    Aug 16, 2002
    hm I wonder if you can downgrade boot camp in lion....maybe its working...maybe not...guess I'll have try tomorrow...tell you then
  20. iMacDragon macrumors 68000


    Oct 18, 2008
    The issue with the booting is EFI, which can't be changed.
  21. Bosslenz thread starter macrumors newbie

    Sep 15, 2011
    Interestingly enough, I just downloaded a Lion chg from Apple addressing an EFI modification. Dare I try to install Windows 7 via Bootcamp again?
  22. iMacDragon macrumors 68000


    Oct 18, 2008
    Last weeks EFI update unfortunately did nothing for this issue, I already tried it.
  23. Bosslenz thread starter macrumors newbie

    Sep 15, 2011
    /What a bummer... I was hoping Apple was reading our highly intellectual and well-researched thread!
  24. spiegs macrumors newbie

    Sep 27, 2011
    Found the solution - it sucks

    I found this thread as I was having the exact same problem. I had removed my MBP's dvd drive and replaced it with a OWC adapter w/ SSD. When trying to install Windows 7 via an external DVD, I always got the no supported devices black screen.

    What I finally did was:
    1. Use the Mac O/S bootcamp setup utility to format my Win 7 drive
    2. Shutdown and removed my factory hard drive, replaced it w/ my windows 7 drive, then put the MBP's DVD drive back in
    3. Upon reboot I was able to install Windows 7
    4. I took out the DVD drive again and replaced the factory HDD and put the OWC w/ SSD in the DVD drive

    Now when I reboot, I'm able to select Windows 7 or Mac OS. Terrible workaround but it did work.
  25. Bosslenz thread starter macrumors newbie

    Sep 15, 2011
    Thanks, I know it's the way to go. Someone else mentioned that it took them a couple of minutes to reinstall the optical drive and install Windows 7 in that fashion.

    I'm just pissed that I have to waste more time doing all of this. I swear. If I go through all of this and I see a OS Lion update addressing this particular issue, I'm going to be one of those crazy people walking down the street mumbling then cursing out loud!

    This means I have to take the optical out of the casing I bought and mess with those tiny ass screws again using the electron microscope. I may just buy a PC laptop and be done with it.

Share This Page