Can't install windows 7?

Discussion in 'Windows, Linux & Others on the Mac' started by Mirage08, Mar 27, 2011.

  1. Mirage08 macrumors newbie

    Aug 31, 2008
    Hey guys. I've been trying to install windows 7 on my late 2008 unibody MBP for a long time now and am finally deciding to seek help. I took out my optical drive in order to put in a solid state drive, so I'm left bootcamping from a USB superdrive.

    When I run the bootcamp assistant to attempt to boot from the external dvdrom I get the error: "BOOTMGR is missing or corrupt. System cannot boot."

    I've tried the rEFIt route to boot a bootable USB copy of windows (which I made on a windows machine) and rEFIt lets me see the drive, but right when I try to boot from it and the white windows logo appears, the screen goes black almost instantly. barely catch a glimpse of the white windows EFI boot logo.

    My OS X install is separated over two drives (i.e. Home folder on one drive and system files/applications on the solid state drive). Not sure if this has something to do with it? Maybe there is some files necessary for the boot that are on one of the drives?

    Anyway. This is extremely aggravating and if anyone can help I will be extremely grateful.

  2. lavrishevo macrumors 68000


    Jan 9, 2007
    Unfortuantly, the only answer I have read is your going to have to put your internal DVD unit back in and install it this way and switch back. Pain the ass but won't take that long.
  3. Mirage08 thread starter macrumors newbie

    Aug 31, 2008
    I've seen it work over usb though? so I'm so confused? Why can't I instal via usb dvdrom :'(
  4. Verix, Mar 28, 2011
    Last edited: Mar 28, 2011

    Verix macrumors regular

    Jul 30, 2010
    Just an idea:
    put the windows DVD in the superdrive, boot up and hold ALT.
    You will see Mac and the Windows boot drives.
    EJECT the windows DVD while in this menu. Put it back in.
    Now boot the windows installer.

    This worked for me when it gave me BOOT_VOLUME errors.
  5. Mirage08 thread starter macrumors newbie

    Aug 31, 2008
    Ya. Tried this. It just ejects the disk right after?
  6. mulo macrumors 68020


    Aug 22, 2010
    Behind you
  7. Mirage08 thread starter macrumors newbie

    Aug 31, 2008
    I tried installing via USB using the exact same procedure in that guide. Still a no go. (used rEFIt).

Share This Page