Can't install Windows 8 through Bootcamp on MacBook Air

Discussion in 'Mac Basics and Help' started by NameUndecided, Nov 19, 2013.

  1. NameUndecided macrumors 6502a

    Joined:
    Mar 28, 2011
    #1
    It's been so nice to have so fewer computer issues since I switch to Mac about four years ago. Today I try to do something with Windows and it's taking a day instead of the hour or so I had in mind…

    I want to be as detailed as I can, so I'm sorry for the super long explanation. A big thank you to anyone who'd like to read through it and might know what could be done to fix this though.

    Here's what I've done and what has happened:

    I made a bootable USB stick from a Windows 8 installer ISO.

    On my 2013 MacBook Air, using Boot Camp Assistant, I downloaded the Windows support files onto that same USB stick and I partitioned my Air's SSD to about 40gb for Win8.

    I reboot with the USB in. (I will say right now that this is the only USB/peripheral thing plugged into my Air at this time.) The Windows installer starts up and it looks okay.

    At the beginning of the install menus, it lists my disks/partitions, in order, as:
    Drive 0 Partition 1: EFI (Type) System
    Drive 0 Partition 2 (Type) Primary
    Drive 0 Partition 3 (Type) Primary
    Bootcamp Partition (can't recall its exact title)

    It tells me it can't install to my Bootcamp partition because it needs to be formatted to NTFS. Seems to be no choice, so I format it to NTFS right there in the Windows installer.

    I hit "next" and it seems to be installing okay.
    "Copying Windows files." Check
    "Getting files ready for installation" It always stops at 91% and gives a message:
    "Windows installation encountered an unexpected error. Verify that the installation sources are accessible, and restart the installation. Error code: 0C0000005"

    My only option is to press "Okay" and it reboots the computer.


    Just in case this is the USB stick's problem, I made a 20gb external HDD into a bootable Windows installer the same as I did with the USB stick, but I get the same issue.

    I've tried, in the Windows setup, deleting the Bootcamp partition and from that blank space I create a new partition right there. Same issue happens.

    THEN…
    When I reboot my MacBook Air, I'll hold the Option key to manually choose a startup option. From here, I can select a disk called "Windows", but of course there is no Windows installed there [yet] so it brings me to the USB's install menu but in a lower resolution. The menu seems like it's the same, except
    Only from here will it tell me that it can't install on my partition because "the selected disk is of the GPT partition style."



    It really seems like there's nothing I can do. You would think that if this was normal for MacBook Air and Boot Camp, I'd be seeing tons of mentions about it when I search for a solution. But why is my Air behaving so different?

    I'm sorry I couldn't explain this all more succinctly. But I think it just comes down to: My Bootcamp partition is an incompatible GPT style(?). And for some reason it only tells me that when I indirectly boot from the USB drive(??).

    Not to say this is definitely Window's or Microsoft's fault. I don't know well enough to insightfully judge. But… just… ****mnit. This sort of endless labyrinthine headache is why I sold my Dell laptop four years ago and never looked back.
     
  2. NameUndecided thread starter macrumors 6502a

    Joined:
    Mar 28, 2011
    #2
    After reading around and Googling some more (lots of Apple Support threads), it seems like Boot Camp causes quite a few people some issues on any Haswell MacBooks.

    It's kind of a bummer, because I really just wanted to install Windows 8.1 very simply on my Air and it's ended up being a very annoying troubleshooting chore.

    It's probably not good at all for the ssd to partition and unpartition and format and reformat and reboot over and over, so I suppose I'll give up on it for the time being.

    /talking to myself.
     
  3. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
  4. NameUndecided thread starter macrumors 6502a

    Joined:
    Mar 28, 2011
    #4
    Thanks. I just had a copy of 8 more readily available, but I will… track down… a copy of 7 and try it and get back with the result.
     
  5. cw75 macrumors newbie

    cw75

    Joined:
    Sep 6, 2009
    Location:
    Texas
    #5
    The Other Option

    Just in case it might be of some help, I have Windows 8.1 running in Parallels on my Summer 2013 11" MacBook Air and it runs great for me with a really good amount of speed. But I only use it to use Publisher, so I don't know how well it does on more resource demanding apps.
     
  6. NameUndecided thread starter macrumors 6502a

    Joined:
    Mar 28, 2011
    #6
    Aside from just wanting to be more familiar with the interface, I also primarily just want to play Arkham Asylum from Steam (Humble Bundle). So I don't know if a virtual system / thing would allow that to work as well.

    I also have had Parallels on my Pro in the past and I didn't like how it sort of entwined itself in the system through menus and folders throughout the system. I'd really like to keep my Air as clean as I can manage. But thank you!
     
  7. Gjwilly macrumors 68030

    Joined:
    May 1, 2011
    Location:
    SF Bay Area
  8. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #8
    Quick search shows that error happens on both Mac and PCs.

    I would guess the USB disk was not created following the proper steps.

    This info for W7
    http://kb.iu.edu/data/bciz.html
     
  9. NameUndecided thread starter macrumors 6502a

    Joined:
    Mar 28, 2011
    #9
    That's certainly how I created my bootable drives (one was usb flash drive, the other an external 20gb drive in case the flash drive was being wonky).

    I created those on my MacBook Pro to use on my Air, however. I've now created a bootable flash for Windows 7 to try that, and I've created it on my Air instead of the Pro just to try something different.

    So now I'm using the Windows7 setup and, hilariously, my mouse and keyboard aren't working at all in its setup menu. I don't know if a usb wired mouse or keyboard would work in this scenario, but I don't have one of either immediately available to try.

    If it means anything: If I try to let it boot from the USB automatically, it's just sitting on a black screen. If I press "option" at startup to choose a drive, and I select the orange USB "windows" icon (the only new boot option that shows), it will then start from the USB. But like I say, I then can't do anything at all with the setup menu.

    I know it's a premium computer and it's made to be used, but I still feel like I'm abusing my poor new Air with all of this rebooting and repartitioning.
     
  10. NameUndecided thread starter macrumors 6502a

    Joined:
    Mar 28, 2011
    #10
  11. NameUndecided thread starter macrumors 6502a

    Joined:
    Mar 28, 2011
    #11
    I've decided to just stay with Windows7 for Boot Camp since it's working just fine.

    I couldn't give my 8 install to give an upgrade option rather than a clean install, and who knows if there will be even more issues after and if I do get 8 installed and working.

    Maybe the process will be easier for Haswell Macs in the next six months or so. It's not the biggest issue at all for me to get 8 installed. I just thought "I'd like to play with Windows 8 and have that on the partition" back when I thought it would be a breeze to set it up. Then it wasn't a breeze and the idea stubbornly stuck and caused me to think far too much about it. Ha! Thanks for everyone's help.
     
  12. pastrychef macrumors 601

    pastrychef

    Joined:
    Sep 15, 2006
    Location:
    New York City, NY
    #12
    It's not just the Haswells. I experienced this exact issue when I was trying to install Windows 8 on my Mac Pro. I tried so many different things that I don't even remember what finally worked. I am so afraid of having to do it again that I made two full backups and stored them in different locations in case my current install ever experiences problems.
     
  13. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #13
    same issue on my MBP early 2011 same percent too 91% tried 5 times last night
     
  14. theRevIsNotDead macrumors member

    theRevIsNotDead

    Joined:
    Aug 17, 2013
    #14
    Same exact issue

    I'm getting the EXACT same issue the OP is getting, fails at 91% every time, no matter what I try. Anyone get a fix for this yet?
     
  15. Gjwilly macrumors 68030

    Joined:
    May 1, 2011
    Location:
    SF Bay Area
    #15
    Are you letting Bootcamp create the USB stick?
    I just installed Windows 7 on a 2011 Air and the Bootcamp process does alter the installation procedure -- it's not just a normal Windows installation followed by installation of the Bootcamp drivers -- the Bootcamp drivers actually get installed before the Windows installation completes.
    Maybe it's the same for Windows 8?
    Anyway, if you haven't actually let Bootcamp create the USB stick you should give it a try.
    If you need a genuine Windows 7 ISO you can get one here:
    http://www.mydigitallife.info/official-windows-7-sp1-iso-from-digital-river/

    If you need Windows 8 you can get it here:
    http://getintopc.com/softwares/operating-systems/download-windows-8-pro/
     

Share This Page