can't jailbreak with redsn0w

Discussion in 'Jailbreaks and iOS Hacks' started by tfyoung, Dec 26, 2011.

  1. tfyoung macrumors newbie

    Joined:
    Sep 2, 2009
    #1
    I have a 3gs, old bootrom. The device was jailbroken and unlocked. Just used redsn0w to upgrade from 4.0 to 5.0.1. Preserved the 04.26.08 baseband. When I try to use redsn0w to jailbreak and install cydia I get the following message:

    "The IPSW for the following build is needed:

    iPhone2,1_5.0.1_9A404

    The required IPSW is either not public or not available right now. Please provide it manually using Extras->Select IPSW."

    The redsn0w version is 0.9.9b9d.

    So at this point, I still have an unlockable baseband, but no cydia and no jailbreak.

    Any help will be appreciated.
     
  2. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #2
    Did you follow the instructions and selected the ipsw file manual in redsn0w?
     
  3. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #3
    1. When restore, you use custom build from redsn0w to restore your phone so you can preserve its baseband.

    2. When jailbreak with redsn0w, you need to point it to stock firmware and not customs firmware.
     
  4. tfyoung thread starter macrumors newbie

    Joined:
    Sep 2, 2009
    #4
    The stock firmware redsn0w ask for is iPhone2,1_5.0.1_9A404

    The stock firmware I used to build the custom IPSW was iPhone2,1_5.0.1_9A405.

    I can't find iPhone2,1_5.0.1_9A404. Does it exist?
     
  5. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #5
    * Windows XP: \Documents and Settings\username\Application Data\Apple Computer\iTunes\iPhone Software Updates
    * Windows Vista & Windows 7: \Users\username\AppData\Roaming\Apple Computer\iTunes\iPhone Software Updates
     
  6. tfyoung thread starter macrumors newbie

    Joined:
    Sep 2, 2009
    #6
    Thanks for the suggestions. However, I don't have the folder:

    Windows 7: \Users\username\AppData\Roaming\Apple Computer\iTunes\iPhone Software Updates

    With fear and trepidation, I'm considering renaming the stock IPSW I used to create the custom IPSW to match the filename requested by redsn0w. Has anybody tried this and what was the result?
     
  7. tfyoung thread starter macrumors newbie

    Joined:
    Sep 2, 2009
    #7
    Okay. I renamed iPhone2,1_5.0.1_9A405_Restore.IPSW that I used to create the custom IPSW for the upgrade. Renamed to iPhone2,1_5.0.1_9A404_Restore.IPSW. After renaming, in redsn0w I selected the file with "manually select IPSW". This seemed to satisfy redsn0w. For the rest of the process redsn0w referred to the file by the original name iPhone2,1_5.0.1_9A405_Restore. But it did finish the process. Loaded Cydia, ect. So far I have SBSettings, weather icon, and a few other things running. So it evidently worked.
     
  8. DRRAC macrumors newbie

    Joined:
    Dec 28, 2011
    #8
    I have the exactly same problem....

    Created custom IPSW using redsnow 0.9.10b1 from iPhone2,1_5.0.1_9A405.

    Uploaded the Custom IPSW using Itunes and it completed all but now my screen is black and i am stuck in DFU mode. I tried to jailbreak and tethered boot but none of it is working, it gives the same message:
    The IPSW for the following build is needed:
    iPhone2,1_5.0.1_9A404

    The required IPSW is either not public or not
    available right now. Please provide it
    manually using "Extras->Select IPSW".

    Note: If you provide this IPSW once, it will be
    cached so that you don't need to provide it again.
    "

    I was just trying to untethered jailbreak to 5.0.1 from 4.0 with preservation of my baseband to use ultrasnow to unlock later.

    Any info would be appreciated. Thx
     
  9. BigRed1 macrumors 6502

    Joined:
    Dec 13, 2011
    #9
    I'm going through this issue right now. I have a 3gs BB 6.15.00 on 5.0.1. Cydia did not install after I went through the process. Now I'm trying to use redsn0w to jailbreak and install Cydia so that I can unlock for use on TMo.

    I got the same error, went back and manually selected the ipsw. Now when I go to jailbreak using redsn0w, I'm nervous because I don't know what I'm doing. I have selected "install iPad baseband" because I am terrified of accidentally changing it by some process. This causes redsn0w to crash each time. If I don't select this, will my baseband be preserved and allow me to simply jailbreak the iPhone?
     
  10. BigRed1 macrumors 6502

    Joined:
    Dec 13, 2011
    #10
    Nevermind, I really am an idiot. I misread some of the directions about 8 times. All is good with the world now.
     
  11. clairity macrumors newbie

    Joined:
    Jan 9, 2012
    #11
    i ran into the same problem trying to upgrade my 3gs to ios 5.0.1 without upgrading the baseband (had to upgrade to itunes 10.5.2 by the way)... i renamed my ipsw file as noted here and was able to get the jailbreak to work (after upgrading to 5.0.1 via the custom ipsw option). besides this error, i was also receiving these other error messages: "unexpected error", “no identifying data fetched”, and "USB communications error" over and over no matter what i tried. i was afraid that it would upgrade my baseband because it was the stock firmware, but it didn't.

    i'm just waiting for my itunes sync to finish now, thanks! :)
     
  12. The Rough Boy macrumors newbie

    Joined:
    Jan 9, 2012
    #12
    Can Someone Help Me Out

    My iPhone 3GS ios 5.0.1
    My SN Begins with 841041
    I Opened RedsnOw Selected IPSw Then I Got This Message Says Is This The Newer (Fixed) Model: Yes or No (Do I Hit Yes or No) Can Someone Help Me

    Is this a newer model of the iPhone? If not sure, you can determine your production week from the serial number in your Settings->General->About screen. The week number is usually the 4th and 5th digit of the serial number, For example, a SN beginning with 88926... would be week 26 of 2009 3GS units made week 45 or later usually have a fixed bootrom before week 40, they usually have the older (Desirable) one, Betwwen weeks 40 and 45, results vary Caution: If you have a newer model and you don't correctly identify it here, you will likely need to do a full official restore to fix the mistake, losing any unsynced data. Note that newer models cannot yet have a custom logos.

    ----------

    My iPhone 3GS ios 5.0.1
    My SN Begins with 841041
    I Opened RedsnOw Selected IPSw Then I Got This Message Says Is This The Newer (Fixed) Model: Yes or No (Do I Hit Yes or No) Can Someone Help Me

    Is this a newer model of the iPhone? If not sure, you can determine your production week from the serial number in your Settings->General->About screen. The week number is usually the 4th and 5th digit of the serial number, For example, a SN beginning with 88926... would be week 26 of 2009 3GS units made week 45 or later usually have a fixed bootrom before week 40, they usually have the older (Desirable) one, Betwwen weeks 40 and 45, results vary Caution: If you have a newer model and you don't correctly identify it here, you will likely need to do a full official restore to fix the mistake, losing any unsynced data. Note that newer models cannot yet have a custom logos.​
     
  13. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #13
    You get the answer on the other post already. Why did you post here again. Hit "Yes".
     
  14. stevez.r macrumors newbie

    Joined:
    Jun 12, 2009
    #14
    I had the same problem here, and apparently solved it by renaming the original IPSW file as suggested above.

    But: if I hit NO whe asked if I have a new bootrom, it then tells me my device does not support untethered jailbreak. My iphone's production week is 16. :confused:

    Anyway, while trying to find a solution I jailbroke it hitting YES and got a tethered jailbreak. I installed ultrasn0w and it worked fine. I tried to install the Corona package to convert the untethered jailbreak to tethered but to no result. :confused: again.

    Any hints would be much appreciated.

    edit: I have an iPhone 3Gs with 06.15.00 baseband
     

Share This Page